summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26a25f000022
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wayst-wayland-git
+ pkgdesc = Simple terminal emulator for Wayland and X11 with OpenGL rendering and minimal dependencies.
+ pkgver = r146.18a038b
+ pkgrel = 1
+ url = https://github.com/91861/wayst
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = mesa
+ depends = freetype2
+ depends = fontconfig
+ depends = libxkbcommon
+ depends = libxrandr
+ optdepends = libutf8proc: unicode normalization
+ provides = wayst
+ conflicts = wayst
+ source = git+https://github.com/91861/wayst.git#branch=master
+ md5sums = SKIP
+
+pkgname = wayst-wayland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..086bcda86297
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: AntonĂ­n Dach <dach@protonmail.com>
+
+pkgname=wayst-wayland-git
+pkgver=r146.18a038b
+pkgrel=1
+pkgdesc='Simple terminal emulator for Wayland and X11 with OpenGL rendering and minimal dependencies.'
+arch=('x86_64')
+url='https://github.com/91861/wayst'
+license=('MIT')
+depends=('mesa' 'freetype2' 'fontconfig' 'libxkbcommon' 'libxrandr')
+optdepends=('libutf8proc: unicode normalization')
+makedepends=('git')
+provides=('wayst')
+conflicts=('wayst')
+source=('git+https://github.com/91861/wayst.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd wayst
+
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+
+}
+
+build() {
+ cd wayst
+
+ make window_protocol=wayland
+}
+
+package() {
+ cd wayst
+
+ mkdir -p "$pkgdir/usr/bin"
+ make INSTALL_DIR="$pkgdir/usr/bin" install
+}