summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Fix-compile-error.patch25
-rw-r--r--PKGBUILD45
3 files changed, 50 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e37e3ebcc8c..b1a9ab06e000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wdt-git
pkgdesc = Tool to transfer data between 2 systems as fast as possible over multiple TCP paths
- pkgver = 1.27.1612021.r95.g03936d5
+ pkgver = 1.27.1612021.r190.g6a122f2
pkgrel = 1
url = https://github.com/facebook/wdt
arch = i686
@@ -10,17 +10,18 @@ pkgbase = wdt-git
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = double-conversion
depends = glibc
depends = bash
+ depends = double-conversion
depends = gflags
depends = google-glog
- depends = openssl-1.0
+ depends = openssl
optdepends = jemalloc
- provides = wdt
+ provides = wdt=1.27.1612021.r190.g6a122f2
conflicts = wdt
source = git+https://github.com/facebook/wdt.git
+ source = git+https://github.com/facebook/folly.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = wdt-git
-
diff --git a/0001-Fix-compile-error.patch b/0001-Fix-compile-error.patch
new file mode 100644
index 000000000000..19d0e6fc9c73
--- /dev/null
+++ b/0001-Fix-compile-error.patch
@@ -0,0 +1,25 @@
+From 587eb38456106d09de3408c7edda93bbfdd7035d Mon Sep 17 00:00:00 2001
+From: Chocobo1 <Chocobo1@users.noreply.github.com>
+Date: Wed, 7 Oct 2020 16:06:14 +0800
+Subject: [PATCH] Fix compile error
+
+https://github.com/facebook/wdt/issues/199
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a061d93..578ca6c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,6 +74,7 @@ set (FOLLY_CPP_SRC
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/ChecksumDetail.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/Crc32cDetail.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/hash/detail/Crc32CombineDetail.cpp"
++"${FOLLY_SOURCE_DIR}/folly/lang/CString.cpp"
+ "${FOLLY_SOURCE_DIR}/folly/ScopeGuard.cpp"
+ )
+
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index fd79e47bc424..8657a025078a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=wdt-git
-pkgver=1.27.1612021.r95.g03936d5
+pkgver=1.27.1612021.r190.g6a122f2
pkgrel=1
pkgdesc="Tool to transfer data between 2 systems as fast as possible over multiple TCP paths"
arch=('i686' 'x86_64')
url="https://github.com/facebook/wdt"
license=('BSD')
-depends=('glibc' 'bash' 'gflags' 'google-glog' 'openssl-1.0')
-makedepends=('git' 'cmake' 'boost' 'double-conversion')
+depends=('glibc' 'bash' 'double-conversion' 'gflags' 'google-glog' 'openssl')
+makedepends=('git' 'cmake' 'boost')
optdepends=('jemalloc')
checkdepends=('gtest')
-provides=('wdt')
+provides=("wdt=$pkgver")
conflicts=('wdt')
-source=("git+https://github.com/facebook/wdt.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/facebook/wdt.git"
+ "git+https://github.com/facebook/folly.git")
+sha256sums=('SKIP'
+ 'SKIP')
-prepare() {
- cd "$srcdir"
-
- rm -rf "folly"
- git clone "https://github.com/facebook/folly.git"
- cd "folly"
- git checkout "$(git describe --abbrev=0 --always)"
-
- cd "$srcdir/wdt"
- mkdir -p "_build"
-}
-
pkgver() {
cd "wdt"
@@ -36,21 +26,24 @@ pkgver() {
}
build() {
- cd "$srcdir/wdt/_build"
+ cd "wdt"
- cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release ../
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ make -C "_build"
}
check() {
- cd "$srcdir/wdt/_build"
+ cd "wdt"
- #CTEST_OUTPUT_ON_FAILURE=1 make test
+ #CTEST_OUTPUT_ON_FAILURE=1 make -C "_build" test
}
package() {
- cd "$srcdir/wdt/_build"
+ cd "wdt"
- make DESTDIR="$pkgdir" install
- install -Dm644 "../LICENSE" "$pkgdir/usr/share/licenses/wdt/LICENSE"
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/wdt"
}