summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.PKGINFO16
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
3 files changed, 68 insertions, 0 deletions
diff --git a/.PKGINFO b/.PKGINFO
new file mode 100644
index 000000000000..339cda03df3c
--- /dev/null
+++ b/.PKGINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.2.1
+# using fakeroot version 1.24
+pkgname = weatherreport
+pkgbase = weatherreport
+pkgver = 1.0.0-1
+pkgdesc = A command line tool to get the current weather conditions.
+url = https://gitlab.com/chrisfair/weatherreport
+builddate = 1588654041
+packager = Unknown Packager
+size = 7229048
+arch = x86_64
+license = GPL
+depend = libalpm.so>=12
+depend = sudo
+depend = git
+makedepend = go
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c33ac3acc672
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = weatherreport
+ pkgdesc = A command line tool to get the current weather conditions.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/chrisfair/weatherreport
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ makedepends = go
+ depends = libalpm.so>=12
+ depends = sudo
+ depends = git
+ source = https://gitlab.com/chrisfair/weatherreport/-/archive/v1.0.0/weatherreport-v1.0.0.tar.gz
+ sha256sums = e2ffe6f0bbd7d4501ff945f847693c7114717d8846f14b38c399328855a802c8
+
+pkgname = weatherreport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96219c20c6b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: quenyen
+pkgname=weatherreport
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A command line tool to get the current weather conditions."
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://gitlab.com/chrisfair/weatherreport"
+license=('GPL')
+depends=(
+ 'libalpm.so>=12'
+ 'sudo'
+ 'git'
+)
+makedepends=(
+ 'go'
+)
+source=("https://gitlab.com/chrisfair/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('e2ffe6f0bbd7d4501ff945f847693c7114717d8846f14b38c399328855a802c8')
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd "$srcdir/$pkgname-v$pkgver"
+ go get github.com/mmcdole/gofeed
+ go build
+}
+
+package() {
+ cd "$srcdir/$pkgname-v$pkgver"
+ install -D $pkgname-v$pkgver $pkgdir/usr/bin/$pkgname
+}
+