summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xupdate.sh23
1 files changed, 23 insertions, 0 deletions
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..82ddce3a4be4
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,23 @@
+#!/bin/bash
+
+#stop on failure
+set -e
+
+echo "Updating to verion $1"
+sed -i -e "s/pkgver=.*/pkgver=$1/g" PKGBUILD
+
+echo "Updating checksums"
+updpkgsums
+
+echo "Updating SRCINFO"
+makepkg --printsrcinfo > .SRCINFO
+
+echo "Commiting changes"
+git add PKGBUILD .SRCINFO
+git commit -m "Update to version $1"
+git clean -d -f
+
+echo "Pushing changes"
+git push
+
+echo "Update Complete :)"