summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD30
-rw-r--r--enchant-2.x.patch11
3 files changed, 29 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c1387f0864f..cdb0dad5fa12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webkitgtk
- pkgdesc = Legacy Web content engine
+ pkgdesc = Legacy Web content engine with enchant 2.x support
pkgver = 2.4.11
- pkgrel = 6
+ pkgrel = 1
url = https://webkitgtk.org/
install = webkitgtk.install
arch = i686
@@ -28,41 +28,20 @@ pkgbase = webkitgtk
optdepends = gst-plugins-base: free media decoding
optdepends = gst-plugins-good: media decoding
optdepends = gst-libav: nonfree media decoding
+ provides = webkitgtk
+ provides = webkitgtk2
options = !emptydirs
source = https://webkitgtk.org/releases/webkitgtk-2.4.11.tar.xz
source = webkitgtk-2.4.9-abs.patch
source = icu59.patch
+ source = enchant-2.x.patch
sha256sums = 588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7
sha256sums = ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70
sha256sums = eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d
+ sha256sums = 81a4ad1c921bece16edb9a3cb187096fd8f336db8b89114356119a86f26e3d6d
-pkgname = webkitgtk
- pkgdesc = Legacy Web content engine for GTK+ 3
- depends = libxt
- depends = libxslt
- depends = sqlite
- depends = libsoup
- depends = enchant
- depends = libgl
- depends = geoclue2
- depends = gst-plugins-base-libs
- depends = libsecret
- depends = libwebp
- depends = harfbuzz-icu
- depends = gtk3
- optdepends = gst-plugins-base: free media decoding
- optdepends = gst-plugins-good: media decoding
- optdepends = gst-libav: nonfree media decoding
- optdepends = gtk2: Netscape plugin support
- provides = webkitgtk3=2.4.11
- provides = libwebkit3=2.4.11
- conflicts = webkitgtk3
- conflicts = libwebkit3
- replaces = webkitgtk3
- replaces = libwebkit3
-
-pkgname = webkitgtk2
- pkgdesc = Legacy Web content engine for GTK+ 2
+pkgname = webkitgtk2-enchant
+ pkgdesc = Legacy Web content engine with enchant 2.x support for GTK+ 2
depends = libxt
depends = libxslt
depends = sqlite
diff --git a/PKGBUILD b/PKGBUILD
index cfcc69060403..5111093f9639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgbase=webkitgtk
-pkgname=(webkitgtk webkitgtk2)
+pkgname=webkitgtk2-enchant
pkgver=2.4.11
-pkgrel=6
-pkgdesc="Legacy Web content engine"
+pkgrel=1
+pkgdesc="Legacy Web content engine with enchant 2.x support"
arch=(i686 x86_64)
url="https://webkitgtk.org/"
license=(custom)
+provides=('webkitgtk' 'webkitgtk2')
depends=(libxt libxslt sqlite libsoup enchant libgl geoclue2 gst-plugins-base-libs
libsecret libwebp harfbuzz-icu)
makedepends=(gtk3 gtk2 gperf gobject-introspection python2 mesa ruby)
@@ -19,10 +20,12 @@ options=(!emptydirs)
install=webkitgtk.install
source=(https://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
webkitgtk-2.4.9-abs.patch
- icu59.patch)
+ icu59.patch
+ enchant-2.x.patch)
sha256sums=('588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7'
'ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70'
- 'eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d')
+ 'eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d'
+ '81a4ad1c921bece16edb9a3cb187096fd8f336db8b89114356119a86f26e3d6d')
prepare() {
mkdir build-gtk{,2} path
@@ -31,6 +34,7 @@ prepare() {
cd $pkgbase-$pkgver
patch -Np1 -i ../webkitgtk-2.4.9-abs.patch
patch -Np1 -i ../icu59.patch
+ patch -Np1 -i ../enchant-2.x.patch
}
_build() (
@@ -56,24 +60,10 @@ _build() (
)
build() {
- _build gtk
_build gtk2 --with-gtk=2.0
}
-package_webkitgtk() {
- pkgdesc+=" for GTK+ 3"
- depends+=(gtk3)
- optdepends+=('gtk2: Netscape plugin support')
- provides=("webkitgtk3=${pkgver}" "libwebkit3=${pkgver}")
- conflicts=(webkitgtk3 libwebkit3)
- replaces=(webkitgtk3 libwebkit3)
-
- make -C build-gtk -j1 DESTDIR="$pkgdir" install
- install -Dm644 $pkgbase-$pkgver/Source/WebKit/LICENSE \
- "$pkgdir/usr/share/licenses/webkitgtk/LICENSE"
-}
-
-package_webkitgtk2() {
+package() {
pkgdesc+=" for GTK+ 2"
depends+=(gtk2)
provides=("libwebkit=${pkgver}")
diff --git a/enchant-2.x.patch b/enchant-2.x.patch
new file mode 100644
index 000000000000..e65c5b88971f
--- /dev/null
+++ b/enchant-2.x.patch
@@ -0,0 +1,11 @@
+--- webkitgtk-2.4.9/Source/WebCore/platform/text/enchant/TextCheckerEnchant.cpp.orig 2017-12-06 14:59:40.768262788 -0500
++++ webkitgtk-2.4.9/Source/WebCore/platform/text/enchant/TextCheckerEnchant.cpp 2017-12-06 15:03:10.000000000 -0500
+@@ -128,7 +128,7 @@
+ for (i = 0; i < numberOfSuggestions; i++)
+ guesses.append(String::fromUTF8(suggestions[i]));
+
+- enchant_dict_free_suggestions(*iter, suggestions);
++ enchant_dict_free_string_list(*iter, suggestions);
+ }
+
+ return guesses; \ No newline at end of file