summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--perl526.patch57
3 files changed, 67 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67fafbdf6688..a89fc44d41a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = webmin
pkgdesc = A web-based administration interface for Unix systems
- pkgver = 1.840
+ pkgver = 1.850
pkgrel = 1
url = http://www.webmin.com/
arch = i686
@@ -125,14 +125,16 @@ pkgbase = webmin
backup = etc/webmin/xinetd/config
backup = etc/logrotate.d/webmin
backup = etc/pam.d/webmin
- source = http://downloads.sourceforge.net/sourceforge/webadmin/webmin-1.840.tar.gz
+ source = http://downloads.sourceforge.net/sourceforge/webadmin/webmin-1.850.tar.gz
+ source = perl526.patch
source = setup-pre.sh
source = setup-post.sh
source = webmin-config.tar.bz2
source = webmin.pam
source = webmin.logrotate
source = webmin.service
- sha256sums = 50cf46850db9c69962d21ef4b935729215044f9ba9de3f2edc40df5ab3bdf201
+ sha256sums = c66caa9e4cb50d5447bc8aceb7989d2284dde060278f404b13e171c7ce1690e1
+ sha256sums = ffec978163a4cfa9ae2fc57ba380ea77b72bf943315796d895b54a21c7f4b29c
sha256sums = 3c27a52679607c73cdaa00c0735bea04cf66cf92ca4af6a7ac906eaed537b910
sha256sums = 21b24cbbf88593f9da727e8f36dea283c8765002a378b3d4e55e6332387c43c6
sha256sums = d326da95233341ed0a6d51c6c28d9b47b5bbe8c1ae8e03e2578c24191dd14383
diff --git a/PKGBUILD b/PKGBUILD
index 26b37750b328..a1e8bcbe73ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Felix Schindler <ftschindler at aur dot archlinux>
pkgname=webmin
-pkgver=1.840
+pkgver=1.850
pkgrel=1
pkgdesc="A web-based administration interface for Unix systems"
arch=(i686 x86_64)
@@ -121,6 +121,7 @@ backup=('etc/webmin/miniserv.conf' 'etc/webmin/miniserv.users' \
'etc/logrotate.d/webmin' \
'etc/pam.d/webmin' )
source=(http://downloads.sourceforge.net/sourceforge/webadmin/$pkgname-$pkgver.tar.gz
+ perl526.patch
setup-pre.sh
setup-post.sh
webmin-config.tar.bz2
@@ -131,6 +132,7 @@ options=(!strip !zipman)
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i ../perl526.patch
# remove modules that we do not support and stuff that is not needed
rm -r {bsdexports,bsdfdisk,cpan,dfsadmin,format,grub,hpuxexports,inetd,ipfilter,ipfw,package-updates,rbac,sgiexports,smf,software,syslog-ng,zones}
@@ -169,7 +171,8 @@ package() {
}
-sha256sums=('50cf46850db9c69962d21ef4b935729215044f9ba9de3f2edc40df5ab3bdf201'
+sha256sums=('c66caa9e4cb50d5447bc8aceb7989d2284dde060278f404b13e171c7ce1690e1'
+ 'ffec978163a4cfa9ae2fc57ba380ea77b72bf943315796d895b54a21c7f4b29c'
'3c27a52679607c73cdaa00c0735bea04cf66cf92ca4af6a7ac906eaed537b910'
'21b24cbbf88593f9da727e8f36dea283c8765002a378b3d4e55e6332387c43c6'
'd326da95233341ed0a6d51c6c28d9b47b5bbe8c1ae8e03e2578c24191dd14383'
diff --git a/perl526.patch b/perl526.patch
new file mode 100644
index 000000000000..69276371b121
--- /dev/null
+++ b/perl526.patch
@@ -0,0 +1,57 @@
+--- webmin-1.850/miniserv.pl 2017-06-25 04:15:46.000000000 +0530
++++ webmin-1.850/miniserv.pl 2017-07-03 10:06:43.628276915 +0530
+@@ -159,8 +159,11 @@
+ }
+ }
+ if ($config{'pam_only'} && !$use_pam) {
+- print STDERR $startup_msg[0],"\n";
++ foreach $msg (@startup_msg) {
++ print STDERR $msg,"\n";
++ }
+ print STDERR "PAM use is mandatory, but could not be enabled!\n";
++ print STDERR "no_pam and pam_only both are set!\n" if ($config{no_pam});
+ exit(1);
+ }
+ elsif ($pam_msg && !$use_pam) {
+--- webmin-1.850/setup.sh 2017-06-25 04:15:46.000000000 +0530
++++ webmin-1.850/setup.sh 2017-07-03 11:45:18.708245816 +0530
+@@ -76,6 +76,7 @@
+ if [ "$perllib" != "" ]; then
+ PERLLIB="$PERLLIB:$perllib"
+ fi
++export PERLLIB
+
+ # Validate source directory
+ allmods=`cd "$srcdir"; echo */module.info | sed -e 's/\/module.info//g'`
+--- webmin-1.850/ldap-useradmin/ldap-useradmin-lib.pl 2017-06-25 04:18:11.000000000 +0530
++++ webmin-1.850/ldap-useradmin/ldap-useradmin-lib.pl 2017-07-03 11:21:16.726941477 +0530
+@@ -417,7 +417,7 @@
+ 'warn' => $_[0]->get_value("shadowWarning") || "",
+ 'inactive' => $_[0]->get_value("shadowInactive") || "",
+ );
+- $user{'pass'} =~ s/^(\!?){[a-z0-9]+}/$1/i;
++ $user{'pass'} =~ s/^(\!?)\{[a-z0-9]+\}/$1/i;
+ $user{'all_ldap_attrs'} = { map { lc($_), scalar($_[0]->get_value($_)) }
+ $_[0]->attributes() };
+ $user{'ldap_class'} = [ $_[0]->get_value('objectClass') ];
+--- webmin-1.850/logrotate/logrotate-lib.pl 2017-06-25 04:18:13.000000000 +0530
++++ webmin-1.850/logrotate/logrotate-lib.pl 2017-07-03 11:38:03.985727637 +0530
+@@ -49,7 +49,7 @@
+ while(<$fh>) {
+ s/\r|\n//g;
+ s/#.*$//;
+- if (/^\s*(.*){\s*$/) {
++ if (/^\s*(.*)\{\s*$/) {
+ # Start of a section
+ push(@name, &split_words($1));
+ $section = { 'name' => [ @name ],
+--- webmin-1.850/system-status/enable-collection.pl 2017-06-25 04:18:35.000000000 +0530
++++ webmin-1.850/system-status/enable-collection.pl 2017-07-03 12:25:34.567937034 +0530
+@@ -1,6 +1,7 @@
+ #!/usr/local/bin/perl
+ # Command-line script to enable status collection
+
++BEGIN { push(@INC, '.'); };
+ use strict;
+ use warnings;
+ our (%config);