summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6073d9c0287e..8e0e15148cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
+# Maintainer: JoaquĆ­n Pino <jpinoz at tuta dot io>
_name="webp-pixbuf-loader"
pkgname="${_name}-git"
-pkgdesc="Enable WebP support in GTK apps"
-pkgver=2022.03.16
+pkgdesc="WebM GDK Pixbuf Loader library - Git version"
+pkgver=0.0.4.r2.g631c1ec
pkgrel=1
url="https://github.com/aruiz/webp-pixbuf-loader"
license=("GPL")
depends=("gdk-pixbuf2" "libwebp")
-makedepends=("meson")
-arch=("i686" "x86_64")
+makedepends=("meson" "git")
+arch=("i686" "x86_64" "i486" "pentium4" "aarch64" "armv7h")
conflicts=("${_name}")
source=("${_name}::git+${url}.git")
sha256sums=("SKIP")
pkgver() {
- cd "${srcdir}/${_name}"
- git log -1 --format="%cd" --date=short | sed 's/-/./g'
+ cd "${_name}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${_name}"
+ cd "${_name}"
arch-meson build
ninja -C build
}