summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ca08e351e5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = webtorrent-cli
+ pkgdesc = WebTorrent, the streaming torrent client. For the command line.
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = https://webtorrent.io
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ source = webtorrent-cli-3.0.5.tar.gz::https://github.com/webtorrent/webtorrent-cli/archive/v3.0.5.tar.gz
+ sha256sums = 6b849e46f4511d2aeaeb93ae544cff6b9c72202ca24388e1aee7ccefb5451296
+
+pkgname = webtorrent-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4e7a6d8972d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Axel Navarro <navarroaxel gmail>
+pkgname=webtorrent-cli
+pkgver=3.0.5
+pkgrel=1
+pkgdesc="WebTorrent, the streaming torrent client. For the command line."
+arch=('any')
+url="https://webtorrent.io"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/webtorrent/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('6b849e46f4511d2aeaeb93ae544cff6b9c72202ca24388e1aee7ccefb5451296')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ npm install --production
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ cp -a bin node_modules package.json "${pkgdir}/usr/lib/${pkgname}/"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -d "$pkgdir/usr/bin"
+ ln -s '/usr/lib/webtorrent-cli/bin/cmd.js' "$pkgdir/usr/bin/webtorrent"
+}