summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5a72d6ad8f..09145104f9fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,14 +11,15 @@ pkgbase = wesnoth-1.2
arch = armv7h
arch = aarch64
license = GPL
- makedepends = gcc43
+ makedepends = gcc44
+ makedepends = git
depends = sdl
depends = sdl_image
depends = sdl_mixer
depends = sdl_net
depends = freetype2
options = !emptydirs
- source = esnoth-1.2-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.2
+ source = wesnoth-1.2-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.2
source = wesnoth-1.2.desktop
source = wesnothd-1.2.tmpfiles.conf
source = wesnothd-1.2.service
diff --git a/PKGBUILD b/PKGBUILD
index a069d2df58de..207bb990507a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+# Maintainer: Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
# This doesn't compile with gcc 4.5, 4.9 or the current versions of gcc or clang.
# It does compile with gcc 4.3.
@@ -11,9 +11,9 @@ arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org"
license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_net' 'freetype2')
-makedepends=('gcc43')
+makedepends=('gcc44' 'git')
options=('!emptydirs')
-source=("esnoth-1.2-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.2"
+source=("wesnoth-1.2-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.2"
"wesnoth-1.2.desktop"
"wesnothd-1.2.tmpfiles.conf"
"wesnothd-1.2.service"
@@ -49,8 +49,8 @@ build() {
unset CFLAGS CXXFLAGS
export CXXFLAGS="-w -pipe"
- export CC=gcc-4.3
- export CXX=g++-4.3
+ export CC=gcc-4.4
+ export CXX=g++-4.4
# It's a convention to use /usr/local when installing by hand, it allows you
# to keep easier track of what was installed.