summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD116
-rw-r--r--wesnoth-devel.appdata.xml102
-rw-r--r--wesnoth-devel.desktop70
-rw-r--r--wesnothd-devel.service29
-rw-r--r--wesnothd-devel.tmpfiles.conf6
5 files changed, 258 insertions, 65 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22f8084f04d1..caa8d2e57e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,81 +2,83 @@
#Maintainer: Andrea Tarocchi <valdar@email.it>
pkgname=wesnoth-devel
-pkgver=1.13.8
+pkgver=1.13.11
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
arch=('i686' 'x86_64')
-url="http://www.wesnoth.org/"
+url="https://www.wesnoth.org/"
license=('GPL')
-depends=('pango>=1.14.8' 'sdl2_ttf>=2.0.0' 'sdl2_net>=2.0.0' 'sdl2_mixer>=2.0.0' 'sdl2_image>=2.0.0' 'fribidi>=0.10.9' 'dbus' 'python2' 'boost-libs' 'lua' 'desktop-file-utils')
-makedepends=('boost>=1.60.0' 'scons>=0.98.3')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'pango' 'fribidi' 'lua' 'dbus' 'openssl' 'boost-libs' 'desktop-file-utils' 'ttf-dejavu' 'ttf-droid' 'ttf-lato')
+optdepends=('python: some tools for UMC developers'
+ 'python2: some tools for UMC developers'
+ 'tk: for GUI.pyw, a gui for some of these tools'
+ 'gettext: for creating translation files with wmlxgettext'
+ 'python-pyenchant: spellchecking with wmllint'
+ 'optipng: png optimization with wesnoth-optipng / woptipng'
+ 'advancecomp: png optimization with wesnoth-optipng / woptipng'
+ 'imagemagick: png optimization with wesnoth-optipng / woptipng'
+ 'libpng: png screenshots')
+makedepends=('boost' 'scons' 'libpng')
install=${pkgname}.install
-source=("http://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
- "${pkgname}.desktop"
- "wesnoth_editor-devel.desktop"
- "wesnoth-devel-icon.xpm"
- "wesnoth-devel_editor-icon.xpm"
- "wesnothd-devel.tmpfiles.conf"
- "wesnothd-devel.service"
- "patch_gcc6.patch")
-
-md5sums=('8f931a2f5a53b8d41c8fb9b47c1eef6d'
-'a906eae5d541a51de77038469b1f794b'
-'b9de9e7ee16f757aa406466657c274a9'
-'b73f4fdefd3e7daa158cce278f11be64'
-'931e7443fe37b2862ca59f65ded74a0b'
-'ffc4b6c06dcd187855710ed96a55fc8f'
-'959aea3af36e7b2a1be6bf4537ec54b7'
-'5182ce65c28a8bd62043c3a7fc09e642')
+options=('!emptydirs')
+#options=('!emptydirs' '!strip') #use this when building with debugging symbols
+source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
+ "${pkgname}.desktop"
+ "wesnoth_editor-devel.desktop"
+ "wesnoth-devel-icon.xpm"
+ "wesnoth-devel_editor-icon.xpm"
+ "wesnothd-devel.tmpfiles.conf"
+ "wesnothd-devel.service"
+ "wesnoth-devel.appdata.xml")
+
+md5sums=('e1c22dd75f4d3edb1504a1dbd51ff750'
+ 'fb3c2d5cfb93c8e8bce213f562c366e9'
+ 'b9de9e7ee16f757aa406466657c274a9'
+ 'b73f4fdefd3e7daa158cce278f11be64'
+ '931e7443fe37b2862ca59f65ded74a0b'
+ 'd9d4677b083eab179200e34c6dea8899'
+ '93f1afc41c66eb324a45ca26055f1507'
+ 'b6da095ff0849b5fd95204702a257496')
PKGEXT='.pkg.tar'
prepare() {
- cd "${srcdir}/wesnoth-$pkgver"
+ cd "$srcdir/wesnoth-$pkgver"
- #How to manually create a patch
+ #How to manually create a patch
#diff -rupN src/ src_new/ > patch_name.patch
- #Patching due to boost 1.60
- #[https://gna.org/bugs/?24227]
- #patch -p1 < ../boost1_60.patch
- #patch -p1 < ../boost1_600tests.patch
+ #How to apply a patch
+ #patch -p1 < ../../sdlmixer_2.0.2.patch
}
build() {
- cd "${srcdir}/wesnoth-$pkgver"
-
- #gcc 6 patching
- #patch -p1 < ../../patch_gcc6.patch
+ cd "$srcdir/wesnoth-$pkgver"
- scons jobs=4 desktop_entry=False prefix=/usr program_suffix=-devel datadirname=wesnoth-devel prefsdir=.wesnoth-devel fifodir=/run/wesnothd-devel \
- boostdir=/usr/include boostlibdir=/usr/include \
- localedir=/usr/share/locale docdir=/usr/share/doc/wesnoth-devel mandir=/usr/share/man/wesnoth-devel python_site_packages_dir=/lib/python/site-packages/wesnoth wesnoth wesnothd campaignd
+ #the option build=debug can be useful if the game crashes and you would like to report a bug
+ scons jobs=4 desktop_entry=False prefix=/usr version_suffix=-devel prefsdir=.wesnoth-devel \
+ docdir=/usr/share/doc/wesnoth-devel mandir=/usr/share/man/wesnoth-devel fifodir=/run/wesnothd-devel \
+ appdata_file=False enable_lto=True openmp=True wesnoth wesnothd
}
package(){
- cd "${srcdir}/wesnoth-$pkgver"
- scons destdir=${pkgdir} boostdir=/usr/include boostlibdir=/usr/include install
-
- #INSTALLING of menu entry and icons:
- install -D -m644 ../../wesnoth-devel.desktop ${pkgdir}/usr/share/applications/wesnoth-devel.desktop
- install -D -m644 ../../wesnoth-devel-icon.xpm ${pkgdir}/usr/share/pixmaps/wesnoth-devel-icon.xpm
- install -D -m644 ../../wesnoth-devel-icon.xpm ${pkgdir}/usr/share/icons/wesnoth-devel-icon.xpm
-
- install -D -m644 ../../wesnoth_editor-devel.desktop ${pkgdir}/usr/share/applications/wesnoth_editor-devel.desktop
- install -D -m644 ../../wesnoth-devel_editor-icon.xpm ${pkgdir}/usr/share/pixmaps/wesnoth-devel_editor-icon.xpm
- install -D -m644 ../../wesnoth-devel_editor-icon.xpm ${pkgdir}/usr/share/icons/wesnoth-devel_editor-icon.xpm
-
- #chmod +x ${pkgdir}/var/run/wesnothd-devel
- #chmod o+r ${pkgdir}/var/run/wesnothd-devel
-
- #rm -f ${pkgdir}/usr/share/applications/wesnoth.desktop
- #rm -f ${pkgdir}/usr/share/applications/wesnoth_editor.desktop
- #rm -f ${pkgdir}/usr/share/icons/wesnoth-icon.png
- #rm -f ${pkgdir}/usr/share/icons/wesnoth_editor-icon.png
- rm -rf ${pkgdir}/run/wesnothd-devel/
- rm -rf ${pkgdir}/run/
+ cd "$srcdir/wesnoth-$pkgver"
+
+ scons destdir="$pkgdir" install
+ cp -r "$srcdir/wesnoth-$pkgver/utils" "$pkgdir/usr/share/$pkgname/"
+
+ #INSTALLING of menu entry and icons and appstream information:
+ install -D -m644 "$srcdir/wesnoth-devel.desktop" "$pkgdir/usr/share/applications/wesnoth-devel.desktop"
+ install -D -m644 "$srcdir/wesnoth-devel-icon.xpm" "$pkgdir/usr/share/pixmaps/$pkgname-icon.xpm"
+
+ install -D -m644 "$srcdir/wesnoth_editor-devel.desktop" "$pkgdir/usr/share/applications/wesnoth_editor-devel.desktop"
+ install -D -m644 "$srcdir/wesnoth-devel_editor-icon.xpm" "$pkgdir/usr/share/pixmaps/$pkgname_editor-icon.xpm"
+
+ install -D -m644 "$srcdir/wesnothd-devel.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-devel.conf"
+ install -D -m644 "$srcdir/wesnothd-devel.service" "$pkgdir/usr/lib/systemd/system/wesnothd-devel.service"
+
+ install -D -m644 "$srcdir/wesnoth-devel.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth-devel.appdata.xml"
- install -Dm644 "$srcdir/wesnothd-devel.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-devel.conf"
- install -Dm644 "$srcdir/wesnothd-devel.service" "$pkgdir/usr/lib/systemd/system/wesnothd-devel.service"
+ #clean up, in case you will use these files not just for building a package
+ sed '/destdir = /d' -i "$srcdir/wesnoth-$pkgver/.scons-option-cache"
}
diff --git a/wesnoth-devel.appdata.xml b/wesnoth-devel.appdata.xml
new file mode 100644
index 000000000000..816a6124c944
--- /dev/null
+++ b/wesnoth-devel.appdata.xml
@@ -0,0 +1,102 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>wesnoth-devel.desktop</id>
+ <metadata_license>GFDL-1.3</metadata_license>
+ <project_license>GPL-2.0+</project_license>
+ <name>Battle for Wesnoth</name>
+ <name xml:lang="de">Battle for Wesnoth</name>
+ <name xml:lang="es">La batalla por Wesnoth</name>
+ <name xml:lang="fr">La Bataille pour Wesnoth</name>
+ <name xml:lang="hu">Harc Wesnothért</name>
+ <name xml:lang="pl">Bitwa o Wesnoth</name>
+ <name xml:lang="ru">Битва за Веснот</name>
+ <summary>A turn-based strategy game with a high fantasy theme</summary>
+ <summary xml:lang="de">Ein rundenbasierendes Strategiespiel mit Fantasy-Thematik</summary>
+ <summary xml:lang="es">Un juego de estrategia basado en turnos con un tema de fantasía</summary>
+ <summary xml:lang="fr">Un jeu de stratégie au tour par tour dans un univers fantastique</summary>
+ <summary xml:lang="hu">Fantasy stílusú, körökre osztott, stratégiai játék</summary>
+ <summary xml:lang="pl">Bitwa o Wesnoth to turowa strategia w klimatach fantasy</summary>
+ <summary xml:lang="ru">Фантастическая пошаговая стратегия</summary>
+ <description>
+ <p>
+ Build up a great army, gradually turning raw recruits into hardened
+ veterans.
+ In later games, recall your toughest warriors and form a deadly host that
+ no one can stand against! Choose units from a large pool of specialists,
+ and hand-pick a force with the right strengths to fight well on different
+ terrains against all manner of opposition.
+ </p>
+ <p xml:lang="de">Stelle eine mächtige Armee zusammen, indem du aus einfachen Rekruten gestählte Veteranen machst. Später kannst du deine härtesten Krieger wieder einberufen, und niemand wird sich dir mehr in den Weg stellen können! Wähle deine Mitstreiter aus einer Anzahl von spezialisierten Einheitentypen und erstelle eine handverlesene Kriegsmacht, mit deren Stärken du dich auf verschiedenem Gelände gegen jede Art von Widerstand behaupten kannst.</p>
+ <p xml:lang="es">Reúne un gran ejercito y convierte progresivamente los reclutas en duros veteranos. ¡Posteriormente reincorpora a tus guerreros más poderosos formando un batallón mortal al que nadie se pueda oponer!. Selecciona unidades entre un gran número de perfiles construyendo un ejercito equilibrado para luchar en diferentes terrenos contra todo tipo de rivales.</p>
+ <p xml:lang="fr">Construisez une grande armée, transformant progressivement de simples recrues en vétérans aguerris. Dans les parties ultérieures, rappelez vos combattants les plus forts et formez une faction meurtrière contre laquelle il est impossible de lutter ! Choisissez des unités parmi un large éventail de spécialistes, et sélectionnez méticuleusement des troupes avec les atouts adéquats pour combattre efficacement sur différents terrains et contre toute sorte d'opposition.</p>
+ <p xml:lang="hu">Építs óriási seregeket, zöldfülű újoncaidat harcedzett veteránokká változtatva! Legkeményebb harcosaidat későbbi pályákon is visszahívhatod, így szinte legyőzhetetlen csapatot alkothatsz. Egységeidet rengeteg típus közül választhatod ki, hogy bármilyen terepen bármilyen ellenfél ellen sikerrel küzdhess meg.</p>
+ <p xml:lang="pl">Stwórz wspaniałą armię, stopniowo rozwijając rekrutów w doświadczonych żołnierzy. W późniejszych grach przywołuj najlepszych wojowników, aby stworzyć niszczycielską drużynę, której nikt nie będzie mógł się przeciwstawić. Wybieraj podwładnych z szerokiej puli wyspecjalizowanych jednostek i stwórz armię, która będzie w stanie skutecznie walczyć na zróżnicowanym terenie z dowolnym wrogiem.</p>
+ <p xml:lang="ru">Создайте великую армию, постепенно превращая неотесанных новобранцев в закаленных ветеранов. В последующих играх призывайте ваших сильнейших воинов и сформируйте из них смертоносный тандем, против которого никто не сможет выстоять! Выбирайте юниты с различными специализациями, подбирайте бойцов с правильными особенностями, чтобы хорошо сражаться на различных территориях и дать отпор против любых маневров врага. </p>
+ <p>
+ Wesnoth has many different sagas waiting to be played.
+ Fight to regain the throne of Wesnoth, of which you are the legitimate
+ heir... lead a brutal quest to unite the orcish tribes... vanquish a horde
+ of undead warriors... Guide a band of elvish survivors in an epic quest to
+ find a new home...
+ </p>
+ <p xml:lang="de">Viele Sagen warten darauf, von dir gespielt zu werden. Kämpfe um den Thron von Wesnoth, dessen legitimer Erbe du bist... schlüpfe in die Rolle eines jungen Offiziers, der ausgesandt wurde, um einen nicht allzu ruhigen Außenposten zu verteidigen... führe einen brutalen Feldzug, um die orkischen Stämme zu vereinigen... besiege eine Gruppe untoter Krieger, die von einem Totenbeschwörer beschworen wurden, der auch deinen Bruder in seiner Gewalt hat... führe eine Gruppe elfischer Überlebender auf ihrer Suche nach einer neuen Heimat...</p>
+ <p xml:lang="es">Wesnoth cuenta con un gran número de campañas esperando a ser jugadas. Lucha por recuperar el trono de Wesnoth del cual eres legítimo heredero... ponte en la piel de un joven oficial enviado a protejer un puesto fronterizo no tan tranquilo como esperaba... lidera la brutal aventura de unir las tribus orcas... derrota una horda de guerreros no muertos invocados por un infecto nigromante que ha raptado a tu hermano... guía a un grupo de supervivientes elfos en su épica búsqueda de un nuevo hogar...</p>
+ <p xml:lang="fr">Wesnoth comporte de nombreuses sagas qui n'attendent que d'être jouées. Luttez pour regagner le trône de Wesnoth, dont vous êtes l'héritier légitime… incarnez un jeune officier envoyé en mission pour garder un avant-poste frontalier pas si paisible… dirigez une quête brutale pour unifier les tribus orcs… surmontez une horde de guerriers morts-vivants contrôlés par un vil nécromancien, qui a par ailleurs pris votre frère en otage… guidez une troupe de survivants elfes dans une quête épique pour trouver une nouvelle terre d'accueil...</p>
+ <p xml:lang="hu">Wesnoth világa számos történetet tartogat. Harcolj Wesnoth trónjáért, amelynek te vagy a jogos örököse... bújj egy fiatal tiszt bőrébe, és vedd át egy nem is annyira nyugodt helyőrség parancsnokságát... egyesítsd az ork törzseket egy kegyetlen hadjáratban... irtsd ki a gonosz holtidéző élőholt seregét, akik mellesleg a bátyádat is túszul ejtették... vezesd tünde túlélők egy kicsiny csoportját egy új haza felé...</p>
+ <p xml:lang="pl">Wesnoth posiada wiele historii gotowych do rozegrania. Walcz aby odzyskać tron Wesnoth, którego jesteś prawowitym spadkobiercą... zasmakuj życia młodego oficera, wysłanego by bronić nie-tak-spokojnej granicy... zniszcz hordę nieumarłych przywołanych przez zuchwałego nekromantę, który porwał też twego brata... poprowadź grupę ocalałych elfów w epickiej wyprawie poszukiwania nowego domu.</p>
+ <p xml:lang="ru">Веснот содержит множество различных саг, которые только и ждут, чтобы быть сыгранными. Сражайтесь за возвращение трона Веснота как его истинный наследник... почувствуйте себя молодым офицером, отправленным на охрану неспокойного передового аванпоста... возглавьте брутальный квест по объединению орочьих племен... сокрушите орду мертвецов, поднятую отвратительным некромантом, который также берет вашего брата в заложники... ведите отряд выживших эльфов в эпическом квесте по поиску нового дома...</p>
+ <p>
+ There are at least two hundred unit types, sixteen races, six major
+ factions, and hundreds of years of history.
+ The world of Wesnoth is absolutely huge and only limited by your
+ creativity.
+ You can also challenge up to eight friends — or strangers — and fight in
+ epic multiplayer fantasy battles.
+ </p>
+ <p xml:lang="de">Mehr als 200 Einheitentypen. 16 Rassen. 6 Hauptfraktionen. Hunderte von Geschichtsjahren. Die Welt Wesnoths ist gigantisch und nur von den Grenzen deiner Vorstellungskraft begrenzt — erstelle deine eigenen Einheiten, Karten, Szenarien oder gleich ganze Kampagnen. Du kannst auch bis zu 8 Personen in epischen Mehrspielerschlachten herausfordern.</p>
+ <p xml:lang="es">Existen más de doscientos tipos de unidades, dieciseis razas, seis facciones principales y cientos de años de historia. El mundo de Wesnoth es absolutamente gigante y sólo está limitado por tu creatividad — construye tus propias unidades personalizadas, elabora tus propios mapas, crea tus propios escenarios o incluso campañas completas. Puedes también retar hasta ocho amigos — o estraños — y luchar en épicas batallas multijugador.</p>
+ <p xml:lang="fr">Plus de 200 types d'unités. 16 races. 6 factions majeures. Des siècles d'histoire. Le monde de Wesnoth est gigantesque et ses seules limites sont votre créativité : créez vos propres unités personnalisées, réalisez vos propres cartes, et écrivez vos propres scénarios voire des campagnes complètes ! Vous pouvez également défier jusqu'à 8 amis — ou inconnus — et les combattre dans d'épiques batailles en mode multijoueur.</p>
+ <p xml:lang="hu">Több, mint kétszáz fajta egység, hatvan faj, hat nagy szövetség és több száz évnyi történelem vár felfedezésre. Wesnoth világa hatalmas és csak a saját képzeleted jelenti a határt. Egyedi egységeket és térképeket készíthetsz, saját küldetéseket vagy akkár hadjáratokat írhatsz. Többjátékos küzdelemre hívhatod ki legfeljebb nyolc barátodat vagy idegeneket.</p>
+ <p xml:lang="pl">Ponad 200 jednostek. 16 ras. 6 głównych frakcji. Setki lat historii. Świat Wesnoth jest niezwykle wielki, ograniczony tylko Twoją wyobraźnią - stwórz własne jednostki, zbuduj własne mapy i napisz własne scenariusze, a nawet całe kampanie. Możesz wyzwać nawet do 8 przyjaciół — lub nieznajomych — aby toczyć epickie bitwy w trybie gry wieloosobowej.</p>
+ <p xml:lang="ru">В игре есть по крайней мере две сотни типов юнитов, шестнадцать рас, шесть крупных фракций и сотни лет истории. Мир Веснота огромен и ограничен только вашей креативностью — создавайте собственные юниты, карты, пишите собственные сценарии или даже полноценные кампании. Вы также можете соревноваться с друзьями или незнакомцами (до 8 человек), сражаясь с ними в эпических многопользовательских фэнтезийных баталиях.</p>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.13.2-1.jpg</image>
+ </screenshot>
+ <screenshot>
+ <caption>Play campaigns and explore the lore</caption>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.13.2-4.jpg</image>
+ </screenshot>
+ <screenshot>
+ <caption>Build up an army of veterans</caption>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.13.6-4.jpg</image>
+ </screenshot>
+ <screenshot>
+ <caption>Create your own maps and campaigns</caption>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.13.7-2.jpg</image>
+ </screenshot>
+ <screenshot>
+ <caption>Fight other players online</caption>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.13.6-1.jpg</image>
+ </screenshot>
+ </screenshots>
+ <launchable type="desktop-id">wesnoth-devel.desktop</launchable>
+ <url type="homepage">https://www.wesnoth.org</url>
+ <url type="faq">https://wiki.wesnoth.org/Play</url>
+ <url type="help">https://wiki.wesnoth.org/WesnothManual</url>
+ <url type="translate">https://wiki.wesnoth.org/WesnothTranslations</url>
+ <url type="bugtracker">https://github.com/wesnoth/wesnoth/issues</url>
+ <project_group>Wesnoth</project_group>
+ <developer_name>The Battle for Wesnoth Project</developer_name>
+ <!-- <update_contact></update_contact> -->
+ <kudos>
+ <kudo>ModernToolkit</kudo>
+ <kudo>Notifications</kudo>
+ <kudo>UserDocs</kudo>
+ </kudos>
+ <provides>
+ <binary>wesnoth-devel</binary>
+ <binary>wesnothd-devel</binary>
+ </provides>
+</component>
diff --git a/wesnoth-devel.desktop b/wesnoth-devel.desktop
index fce664f9f04e..913bacd615c3 100644
--- a/wesnoth-devel.desktop
+++ b/wesnoth-devel.desktop
@@ -5,38 +5,98 @@ Type=Application
Name=Battle for Wesnoth (devel)
Name[af]=Die Stryd vir Wesnoth (devel)
Name[ca]=Batalla per Wesnoth (devel)
+Name[cs]=Bitva o Wesnoth (devel)
+Name[de]=Battle for Wesnoth (devel)
Name[dk]=Kampen om Wesnoth (devel)
+Name[es]=La batalla por Wesnoth (devel)
Name[eu]=Wesnotheko Guda (devel)
+Name[fi]=Taistelu Wesnothista (devel)
Name[fr]=La Bataille pour Wesnoth (devel)
+Name[gl]=A batalla polo Noroeste (devel)
Name[he]=הקרב על ווסנות (devel)
-Name[hu]=Harc Wesnoth-ért (devel)
+Name[hu]=Harc Wesnothért (devel)
+Name[it]=Battle for Wesnoth (devel)
+Name[lt]=Mūšis dėl Vesnoto (devel)
+Name[pt]=A Batalha por Wesnoth (devel)
Name[ru]=Битва за Веснот (devel)
Name[sk]=Bitka o Wesnoth (devel)
+Name[sr]=Бој за Веснот (devel)
+Name[sr@ijekavian]=Бој за Веснот (devel)
+Name[sr@ijekavianlatin]=Boj za Vesnot (devel)
+Name[sr@latin]=Boj za Vesnot (devel)
+Name[tr]=Wesnoth Savaşı (devel)
+Name[vi]=Trận chiến vì Wesnoth (devel)
GenericName=Strategy Game
GenericName[af]=Strategie-spel
GenericName[ca]=Joc d'estrategia
+GenericName[cs]=Strategická hra
GenericName[de]=Strategiespiel
GenericName[dk]=Strategi-spil
+GenericName[es]=Juego de estrategia
GenericName[eu]=Estrategiako jokoa
+GenericName[fi]=Strategiapeli
GenericName[fr]=Jeu de stratégie
+GenericName[gl]=Xogo de estratexia
GenericName[he]=משחק אסטרטגיה
GenericName[hu]=Stratégia
+GenericName[it]=Gioco strategico
+GenericName[lt]=Strateginis žaidimas
+GenericName[pt]=Jogo de Estratégia
GenericName[ru]=Стратегическая игра
GenericName[sk]=Strategická hra
+GenericName[sr]=Стратешка игра
+GenericName[sr@latin]=Strateška igra
+GenericName[tr]=Strateji Oyunu
+GenericName[vi]=Trò chơi chiến lược
Comment=A fantasy turn-based strategy game
Comment[af]='n Fantasie beurt-basis strategie-spel
Comment[ca]=Un joc fantàstic d'estrategia per torns
+Comment[cs]=Tahová strategická hra ve fantastickém prostředí
Comment[de]=Rundenbasiertes Strategiespiel im Fantasyszenario
Comment[dk]=Et fantasy træk-baseret strategi-spil
+Comment[es]=Un juego de estrategia basado en turnos con un tema de fantasía
Comment[eu]=Giro fantastikoan eta txandetan oinarritutako estrategia jokoa
+Comment[fi]=Vuoropohjainen fantasiastrategiapeli
Comment[fr]=Un jeu de stratégie au tour par tour dans un univers fantastique
+Comment[gl]=Xogo de estratexia por quendas ambientado nun mundo fantástico
Comment[he]=משחק אסטרטגיה ופנטסיה מבוסס מהלכים
-Comment[hu]=Egy körökre osztott fantasy stratégia
+Comment[hu]=Fantasy stílusú, körökre osztott, stratégiai játék
+Comment[it]=Un gioco strategico a turni con ambientazione fantasy
+Comment[lt]=Fantastinis ėjimais pagrįstas strateginis žaidimas
+Comment[pt]=Um jogo de fantasia estratégico em turnos
Comment[ru]=Фантастическая пошаговая стратегия
Comment[sk]=Ťahová strategická hra z prostredia fantasy
-Icon=wesnoth-devel-icon.xpm
-FilePattern=wesnoth-devel
-TryExec=wesnoth-devel
+Comment[sr]=Фантазијска стратешка игра на потезе
+Comment[sr@latin]=Fantazijska strateška igra na poteze
+Comment[tr]=Fantastik, sırayla oynanan bir strateji oyunu
+Comment[vi]=Một trò chơi chiến lược dựa trên lượt đi theo phong cách thần thoại
+Icon=wesnoth-devel-icon
Exec=wesnoth-devel
Categories=Game;StrategyGame;
+Actions=Editor;
+[Desktop Action Editor]
+Name=Map Editor
+#Name[af]=
+#Name[ca]=
+Name[cs]=Editor map
+Name[de]=Karteneditor
+#Name[dk]=
+Name[es]=Editor de mapas
+#Name[eu]=
+Name[fi]=Kenttäeditori
+Name[fr]=Éditeur de cartes
+Name[gl]=Editor de mapas
+#Name[he]=
+Name[hu]=pályaszerkesztő
+Name[it]=Editor delle mappe
+Name[lt]=žemėlapių redaktorius
+Name[pt]=Editor de mapas
+#Name[ru]=
+Name[sr]=Уређивач мапа
+Name[sr@ijekavian]=Уређивач мапа
+Name[sr@ijekavianlatin]=Uređivač mapa
+Name[sr@latin]=Uređivač mapa
+Name[tr]=Harita Düzenleyici
+#Name[vi]=
+Exec=wesnoth-devel -e
diff --git a/wesnothd-devel.service b/wesnothd-devel.service
index 7d6fedea6a73..1ff24c2a642c 100644
--- a/wesnothd-devel.service
+++ b/wesnothd-devel.service
@@ -1,9 +1,34 @@
[Unit]
Description=Wesnoth-devel Server Daemon
+Documentation=https://www.wesnoth.org/wiki/ServerAdministration
+Documentation=man:/usr/share/man/wesnoth-devel/man6/wesnothd.6.gz
After=network.target
+Conflicts=wesnothd.service
[Service]
-ExecStart=/usr/bin/wesnothd-devel
+ExecStart=/usr/bin/wesnothd-devel -t 2 -T 5
+# you can use -c to specify the same configuration file
+# which is used when starting wensothd from the wesnoth UI
+# (and make sure wesnothd has the required access permissions)
+
+SyslogIdentifier=Wesnothd-devel
+User=nobody
+Group=nobody
+ExecStopPost=/usr/bin/rm -f /run/wesnothd-devel/socket
+
+# Additional security-related features
+ProtectSystem=yes
+PrivateTmp=yes
+PrivateDevices=yes
+NoNewPrivileges=yes
+RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
+RestrictRealtime=yes
+MemoryDenyWriteExecute=yes
+SystemCallArchitectures=native
+ProtectControlGroups=yes
+ProtectKernelTunables=yes
+ProtectKernelModules=yes
+RestrictNamespaces=yes
[Install]
-WantedBy=multi-user.target \ No newline at end of file
+WantedBy=multi-user.target
diff --git a/wesnothd-devel.tmpfiles.conf b/wesnothd-devel.tmpfiles.conf
index feebe2f9a3f9..284ff56d4e76 100644
--- a/wesnothd-devel.tmpfiles.conf
+++ b/wesnothd-devel.tmpfiles.conf
@@ -1 +1,5 @@
-d /run/wesnothd-devel 0700 root root - \ No newline at end of file
+# This directory is used to store a named pipe, which accepts administration commands
+# See https://wiki.wesnoth.org/ServerAdministration (without /query)
+#
+# wesnothd can either be started by the systemd service file or the wesnoth UI
+d /run/wesnothd-devel 0770 nobody users -