summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..236f8d805e50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wessus
+ pkgdesc = Wessus identifies vulnerabilities in websites identifying technologies and checking related CVE for the specific version.
+ pkgver = 1.1
+ pkgrel = 0
+ url = https://gitlab.com/brn1337/wessus
+ arch = any
+ license = CC BY-NC-SA 4.0
+ makedepends = make
+ depends = npm
+ depends = python
+ depends = chromium
+ source = https://gitlab.com/brn1337/wessus/-/archive/1.1/wessus-1.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = wessus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8129b97fb8eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer 5amu <v.casalino@protonmail.com>
+
+pkgname=wessus
+pkgver=1.1
+pkgrel=0
+pkgdesc="Wessus identifies vulnerabilities in websites identifying technologies and checking related CVE for the specific version."
+url="https://gitlab.com/brn1337/wessus"
+license=('CC BY-NC-SA 4.0')
+arch=('any')
+depends=('npm' 'python' 'chromium')
+makedepends=('make')
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=("SKIP")
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make PREFIX=$pkgdir/usr install
+} \ No newline at end of file