summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--0001-gl-renderer-Add-EGLDevice-enumeration-support.patch2
-rw-r--r--0002-gl-renderer-Add-support-for-EGLDevice-composited-fra.patch2
-rw-r--r--0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch2
-rw-r--r--0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch2
-rw-r--r--0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch2
-rw-r--r--0006-compositor-Process-stream-attach-requests-with-wl_eg.patch17
-rw-r--r--0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch2
-rw-r--r--0008-gl-renderer-Use-mailbox-streams-for-scanout.patch2
-rw-r--r--0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch36
-rw-r--r--PKGBUILD23
11 files changed, 76 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 064dfaa93604..d96488c557f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = weston-eglstream
pkgdesc = Reference implementation of a Wayland compositor with EGLStream support
pkgver = 5.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://wayland.freedesktop.org/
arch = i686
arch = x86_64
@@ -45,15 +45,17 @@ pkgbase = weston-eglstream
source = 0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
source = 0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch
source = 0008-gl-renderer-Use-mailbox-streams-for-scanout.patch
+ source = 0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch
sha256sums = 15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf
- sha256sums = 467c25f7158e54736ed7e9d071c8524e0f83509defcea49a7b053b11be1e9f93
- sha256sums = b60522d00263f1e67e4d4ca823550c1c90f30be450facd9a95fca7a91376b160
- sha256sums = 7ae690d0f75c8e341efea4a2b1f3557a0aec481fa38fe732b61805f9ee530b03
- sha256sums = 4845734de15fa99dbfc7e58b364996a72f63cf3632793d57eca7f696d3d6186e
- sha256sums = 037632c607638d98cf04cb5f1d5754842b77670671358ef34629c8c9dc2d9d19
- sha256sums = d1197824dda263bdde19312095125295a87d773e46fae62d68297d38a810e7f6
- sha256sums = 7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f
- sha256sums = ca1af82fddca20ed2256bff8abad2c726380f0c244c0d7bd75cc1def8e07493b
+ sha256sums = 270c2f68bb84a0f1f670eddb44b3f77729cf29ceecddbe4e62a5ced80fb1d1df
+ sha256sums = f4f79611d00847c722e476469f74dc8fce812afdf2fed58ca91235b04bfe0107
+ sha256sums = 17c8d59665ad33d3dbfea39d8c32634dac660cf528313b51c7064ce27b93ddec
+ sha256sums = f5c7ae1142b2cb0dcf28c4b217c7cac42ab98fb1bb5ee14a2978fa8cc9bc6ea7
+ sha256sums = 59287416cf0a57b76f7e77b7eadf0cf9c91afe480b0c400998abafe2deeb3126
+ sha256sums = 5917fe7b0b49a1d66c3262958c004ffe22de7bb5026856f92cf5be46e81f9b1e
+ sha256sums = 9b910c9b7176a4caea796a11ffd5086a54fe7b3c02336d494b8ea050933cfcbe
+ sha256sums = 840166cc83641e6502c119ea1ff060be3afc1c99c0da792e7e43364ad29e799d
+ sha256sums = d84cea4d89f79215adb148e5ed2afe7e94f3ef66df10e2bbecfddf9f04bd13e4
pkgname = weston-eglstream
diff --git a/0001-gl-renderer-Add-EGLDevice-enumeration-support.patch b/0001-gl-renderer-Add-EGLDevice-enumeration-support.patch
index 377c7fc25e9e..99279dd08d30 100644
--- a/0001-gl-renderer-Add-EGLDevice-enumeration-support.patch
+++ b/0001-gl-renderer-Add-EGLDevice-enumeration-support.patch
@@ -1,7 +1,7 @@
From 0592a2a1b337880ce74d621297d10c988972efd1 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Mon, 2 May 2016 15:56:37 +0200
-Subject: [PATCH 1/8] gl-renderer: Add EGLDevice enumeration support
+Subject: [PATCH 1/9] gl-renderer: Add EGLDevice enumeration support
X-NVConfidentiality: public
EGLDevice provides means to enumerate native devices.
diff --git a/0002-gl-renderer-Add-support-for-EGLDevice-composited-fra.patch b/0002-gl-renderer-Add-support-for-EGLDevice-composited-fra.patch
index b3fae87cbac8..fd5b7e19261d 100644
--- a/0002-gl-renderer-Add-support-for-EGLDevice-composited-fra.patch
+++ b/0002-gl-renderer-Add-support-for-EGLDevice-composited-fra.patch
@@ -1,7 +1,7 @@
From db0add622cd4f8594222e493e164bfb3224230e5 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Mon, 2 May 2016 16:34:01 +0200
-Subject: [PATCH 2/8] gl-renderer: Add support for EGLDevice composited frame
+Subject: [PATCH 2/9] gl-renderer: Add support for EGLDevice composited frame
presentation
X-NVConfidentiality: public
diff --git a/0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch b/0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch
index dec2adb7dcde..6d815d1c15aa 100644
--- a/0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch
+++ b/0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch
@@ -1,7 +1,7 @@
From 1ec5af6e4f51004856d7aee2184d7e4fe11ef086 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Thu, 29 Mar 2018 00:15:49 -0700
-Subject: [PATCH 3/8] gl-renderer: Add EGL client support for EGLStream frame
+Subject: [PATCH 3/9] gl-renderer: Add EGL client support for EGLStream frame
presentation
X-NVConfidentiality: public
diff --git a/0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch b/0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch
index 744a4f766aff..06be3432166c 100644
--- a/0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch
+++ b/0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch
@@ -1,7 +1,7 @@
From 51f88599bea32521399f572e02da6f7ff1557172 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Tue, 1 Mar 2016 22:19:14 +0100
-Subject: [PATCH 4/8] compositor-drm: Gracefully handle vblank and flip invalid
+Subject: [PATCH 4/9] compositor-drm: Gracefully handle vblank and flip invalid
timestamps
X-NVConfidentiality: public
diff --git a/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch b/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch
index 3b9fce0898f4..5c17f3c834de 100644
--- a/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch
+++ b/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch
@@ -1,7 +1,7 @@
From a2a230463cf0bbbf452d40019f7e2aa31f6c7f1d Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Thu, 28 Jan 2016 19:37:10 +0100
-Subject: [PATCH 5/8] compositor-drm: Add support for EGLDevice+EGLOutput
+Subject: [PATCH 5/9] compositor-drm: Add support for EGLDevice+EGLOutput
X-NVConfidentiality: public
As previously stated, EGLDevice and EGLOutput will provide means
diff --git a/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch b/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
index 6cb2161a7ccc..a05dc4b75a55 100644
--- a/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
+++ b/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
@@ -1,7 +1,7 @@
From 9036a214efffea4c2eb13e1d275c59621ee17a52 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Thu, 18 May 2017 14:35:36 -0700
-Subject: [PATCH 6/8] compositor: Process stream attach requests with
+Subject: [PATCH 6/9] compositor: Process stream attach requests with
wl_eglstream_controller
X-NVConfidentiality: public
@@ -31,30 +31,31 @@ requests.
Signed-off-by: Ashutosh Agarwal <asagarwal@nvidia.com>
Signed-off-by: Miguel A Vico Moya <mvicomoya@nvidia.com>
---
- Makefile.am | 14 ++++
+ Makefile.am | 15 ++++
configure.ac | 4 ++
libweston/compositor.c | 78 +++++++++++++++++++++
libweston/compositor.h | 4 ++
libweston/gl-renderer.c | 147 +++++++++++++++++++++++++---------------
- 5 files changed, 193 insertions(+), 54 deletions(-)
+ 5 files changed, 194 insertions(+), 54 deletions(-)
diff --git a/Makefile.am b/Makefile.am
-index 83bb2533..ac24e1dd 100644
+index 83bb2533..c15bca01 100644
--- a/Makefile.am
+++ b/Makefile.am
-@@ -173,6 +173,11 @@ nodist_libweston_@LIBWESTON_MAJOR@_la_SOURCES = \
+@@ -173,6 +173,12 @@ nodist_libweston_@LIBWESTON_MAJOR@_la_SOURCES = \
BUILT_SOURCES += $(nodist_libweston_@LIBWESTON_MAJOR@_la_SOURCES)
-+nodist_libweston_eglstreams_@LIBWESTON_MAJOR@_la_SOURCES = \
++libweston_eglstreams_@LIBWESTON_MAJOR@dir = $(top_builddir)/protocol
++nodist_libweston_eglstreams_@LIBWESTON_MAJOR@_HEADERS = \
+ protocol/wayland-eglstream-controller-server-protocol.h
+
-+BUILT_SOURCES += $(nodist_libweston_eglstreams_@LIBWESTON_MAJOR@_la_SOURCES)
++BUILT_SOURCES += $(nodist_libweston_eglstreams_@LIBWESTON_MAJOR@_HEADERS)
+
bin_PROGRAMS += weston
weston_LDFLAGS = -export-dynamic
-@@ -1658,6 +1663,15 @@ protocol/%-server-protocol.h : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostabili
+@@ -1658,6 +1664,15 @@ protocol/%-server-protocol.h : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostabili
protocol/%-client-protocol.h : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostability,$$*)/$$(call protoname,$$*)/$$*.xml
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) client-header < $< > $@
diff --git a/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch b/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch
index aaab3bc0f83c..474ff386712f 100644
--- a/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch
+++ b/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch
@@ -1,7 +1,7 @@
From 27266e389b238f023f8789fec40ae661541372e4 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Mon, 27 Feb 2017 15:31:35 -0800
-Subject: [PATCH 7/8] simple-egl: Do not set EGL up until XDG setup is complete
+Subject: [PATCH 7/9] simple-egl: Do not set EGL up until XDG setup is complete
X-NVConfidentiality: public
There is nothing that prohibits the underlying EGL_PLATFORM_WAYLAND
diff --git a/0008-gl-renderer-Use-mailbox-streams-for-scanout.patch b/0008-gl-renderer-Use-mailbox-streams-for-scanout.patch
index c7f1e08bb3aa..aa31348a82b8 100644
--- a/0008-gl-renderer-Use-mailbox-streams-for-scanout.patch
+++ b/0008-gl-renderer-Use-mailbox-streams-for-scanout.patch
@@ -1,7 +1,7 @@
From db3147b5446334d69d1ffdb07234babc292dec2e Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Wed, 16 Jan 2019 14:16:30 -0800
-Subject: [PATCH 8/8] gl-renderer: Use mailbox streams for scanout
+Subject: [PATCH 8/9] gl-renderer: Use mailbox streams for scanout
X-NVConfidentiality: public
Ever since flip-event-based output repaints have been used, FIFO mode
diff --git a/0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch b/0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch
new file mode 100644
index 000000000000..15990c07a354
--- /dev/null
+++ b/0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch
@@ -0,0 +1,36 @@
+From c5c8d75dd72b44076af00fa4f0dcfbdb5b9c9f2f Mon Sep 17 00:00:00 2001
+From: "Miguel A. Vico" <mvicomoya@nvidia.com>
+Date: Tue, 26 Mar 2019 15:44:26 -0700
+Subject: [PATCH 9/9] configure: Temporary fix for gobject-2.0 libs missing in
+ pango pkgconfig
+X-NVConfidentiality: public
+
+This fixes the following build error, until the pango pkgconfig is
+restored to also include the corresponding flags to link against
+gobject-2.0:
+
+ /usr/bin/ld: clients/weston_editor-editor.o: undefined reference to symbol 'g_object_unref'
+ /usr/bin/ld: /usr/lib/libgobject-2.0.so.0: error adding symbols: DSO missing from command line
+ collect2: error: ld returned 1 exit status
+
+Signed-off-by: Miguel A Vico Moya <mvicomoya@nvidia.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b219d2e2..18cdfecb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -462,7 +462,7 @@ if test x$enable_clients = xyes; then
+ [AC_ERROR([cairo-egl not used because $CAIRO_EGL_PKG_ERRORS])])],
+ [have_cairo_egl=no])
+
+- PKG_CHECK_MODULES(PANGO, [pangocairo pango glib-2.0 >= 2.36], [have_pango=yes], [have_pango=no])
++ PKG_CHECK_MODULES(PANGO, [pangocairo pango glib-2.0 >= 2.36 gobject-2.0 >= 2.36], [have_pango=yes], [have_pango=no])
+ fi
+
+ AC_ARG_ENABLE(resize-optimization,
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index b5bdb60f7a1d..de4d532bfc43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=weston-eglstream
pkgver=5.0.0
-pkgrel=4
+pkgrel=5
pkgdesc='Reference implementation of a Wayland compositor with EGLStream support'
arch=('i686' 'x86_64')
url='https://wayland.freedesktop.org/'
@@ -25,16 +25,18 @@ source=("https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz"
'0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch'
'0006-compositor-Process-stream-attach-requests-with-wl_eg.patch'
'0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch'
- '0008-gl-renderer-Use-mailbox-streams-for-scanout.patch')
+ '0008-gl-renderer-Use-mailbox-streams-for-scanout.patch'
+ '0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch')
sha256sums=('15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf'
- '467c25f7158e54736ed7e9d071c8524e0f83509defcea49a7b053b11be1e9f93'
- 'b60522d00263f1e67e4d4ca823550c1c90f30be450facd9a95fca7a91376b160'
- '7ae690d0f75c8e341efea4a2b1f3557a0aec481fa38fe732b61805f9ee530b03'
- '4845734de15fa99dbfc7e58b364996a72f63cf3632793d57eca7f696d3d6186e'
- '037632c607638d98cf04cb5f1d5754842b77670671358ef34629c8c9dc2d9d19'
- 'd1197824dda263bdde19312095125295a87d773e46fae62d68297d38a810e7f6'
- '7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f'
- 'ca1af82fddca20ed2256bff8abad2c726380f0c244c0d7bd75cc1def8e07493b')
+ '270c2f68bb84a0f1f670eddb44b3f77729cf29ceecddbe4e62a5ced80fb1d1df'
+ 'f4f79611d00847c722e476469f74dc8fce812afdf2fed58ca91235b04bfe0107'
+ '17c8d59665ad33d3dbfea39d8c32634dac660cf528313b51c7064ce27b93ddec'
+ 'f5c7ae1142b2cb0dcf28c4b217c7cac42ab98fb1bb5ee14a2978fa8cc9bc6ea7'
+ '59287416cf0a57b76f7e77b7eadf0cf9c91afe480b0c400998abafe2deeb3126'
+ '5917fe7b0b49a1d66c3262958c004ffe22de7bb5026856f92cf5be46e81f9b1e'
+ '9b910c9b7176a4caea796a11ffd5086a54fe7b3c02336d494b8ea050933cfcbe'
+ '840166cc83641e6502c119ea1ff060be3afc1c99c0da792e7e43364ad29e799d'
+ 'd84cea4d89f79215adb148e5ed2afe7e94f3ef66df10e2bbecfddf9f04bd13e4')
prepare() {
cd weston-$pkgver
@@ -46,6 +48,7 @@ prepare() {
patch -Np1 -i "${srcdir}/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch"
patch -Np1 -i "${srcdir}/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch"
patch -Np1 -i "${srcdir}/0008-gl-renderer-Use-mailbox-streams-for-scanout.patch"
+ patch -Np1 -i "${srcdir}/0009-configure-Temporary-fix-for-gobject-2.0-libs-missing.patch"
}
build() {