aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.travis.yml (renamed from .travis-ci.yml)0
-rw-r--r--PKGBUILD42
-rwxr-xr-xwexond.sh (renamed from wexond)2
4 files changed, 21 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419acaa545c8..d30d986046fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = wexond
+pkgbase = wexond-appimage
pkgdesc = A privacy-focused, extensible and beautiful web browser
pkgver = 2.2.3
pkgrel = 1
@@ -6,16 +6,15 @@ pkgbase = wexond
arch = i686
arch = x86_64
license = GPL
- makedepends = p7zip
provides = wexond
conflicts = wexond
options = !strip
- source = wexond
+ source = wexond.sh
sha256sums = SKIP
source_i686 = wexond-2.2.3.AppImage::https://github.com/wexond/wexond/releases/download/v2.2.3/wexond-2.2.3-i386.AppImage
sha256sums_i686 = 6810f89c1af92eab502c3be5e9d93d3c2be4f8fea2e699cd72c8693cace30c84
source_x86_64 = wexond-2.2.3.AppImage::https://github.com/wexond/wexond/releases/download/v2.2.3/wexond-2.2.3-x86_64.AppImage
sha256sums_x86_64 = ea1906f136c154520e7bc599e2ab6fd439ca74ef473e49f4e454930d8faf6619
-pkgname = wexond
+pkgname = wexond-appimage
diff --git a/.travis-ci.yml b/.travis.yml
index e2be3aa43b9d..e2be3aa43b9d 100644
--- a/.travis-ci.yml
+++ b/.travis.yml
diff --git a/PKGBUILD b/PKGBUILD
index de128204f623..bbee2fd35dc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: Étienne Deparis <etienne@depar.is>
+# Maintainer: Zadkiel <hello@zadkiel.fr>
+# Repository: https://github.com/aslafy-z/aur-wexond-appimage
+# TODO: Install license file
+# TODO: Re-enable sandbox
-pkgname=wexond
+pkgname=wexond-appimage
pkgver=2.2.3
pkgrel=1
pkgdesc='A privacy-focused, extensible and beautiful web browser'
arch=('i686' 'x86_64')
url='https://github.com/wexond/wexond'
license=('GPL')
-makedepends=('p7zip')
options=('!strip')
provides=(wexond)
conflicts=(wexond)
-source=('wexond')
+source=('wexond.sh')
source_i686=("wexond-${pkgver}.AppImage::https://github.com/wexond/wexond/releases/download/v${pkgver}/wexond-${pkgver}-i386.AppImage")
source_x86_64=("wexond-${pkgver}.AppImage::https://github.com/wexond/wexond/releases/download/v${pkgver}/wexond-${pkgver}-x86_64.AppImage")
sha256sums=(SKIP)
@@ -19,34 +21,24 @@ sha256sums_i686=('6810f89c1af92eab502c3be5e9d93d3c2be4f8fea2e699cd72c8693cace30c
sha256sums_x86_64=('ea1906f136c154520e7bc599e2ab6fd439ca74ef473e49f4e454930d8faf6619')
prepare() {
- cd $srcdir
- chmod u+x wexond-${pkgver}.AppImage
+ chmod u+x "${srcdir}/wexond-${pkgver}.AppImage"
./wexond-${pkgver}.AppImage --appimage-extract 2> /dev/null
}
build() {
- cd $srcdir
- sed -i "s/^Exec=AppRun$/Exec=$pkgname/" squashfs-root/wexond.desktop
- # sed -i "s/^Categories=AudioVideo/Categories=Video;Player;AudioVideo/" squashfs-root/molotov.desktop
- sed -i "s/WEXOND_VERSION/${pkgver}/g" wexond
+ sed -i "s/^Exec=AppRun$/Exec=${pkgname}/" "${srcdir}/squashfs-root/wexond.desktop"
+ sed -i "s/\${pkgver}/${pkgver}/" "${srcdir}/wexond.sh"
}
package() {
- cd $srcdir
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor"
+ install -d -m755 "${pkgdir}/opt/appimages"
- install -d -m755 $pkgdir/usr/share/{applications,icons/hicolor}
- install -d -m755 $pkgdir/opt/appimages
- # TODO find a decent license
- #install -d -m755 $pkgdir/usr/share/licenses/$pkgname
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor/0x0/apps"
+ install -D -m644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/wexond.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/wexond.png"
- hicolor="squashfs-root/usr/share/icons/hicolor"
- for size in $(ls -1 $hicolor); do
- install -d -m755 $pkgdir/usr/share/icons/hicolor/$size/apps
- install -D -m644 $hicolor/$size/apps/wexond.png $pkgdir/usr/share/icons/hicolor/$size/apps/wexond.png
- done
-
- install -D -m644 squashfs-root/wexond.desktop $pkgdir/usr/share/applications/appimagekit-wexond.desktop
- install -D -m755 wexond $pkgdir/usr/bin/wexond
- install -D -m755 wexond-$pkgver.AppImage $pkgdir/opt/appimages/wexond-$pkgver.AppImage
- rm -r squashfs-root
+ install -D -m644 "${srcdir}/squashfs-root/wexond.desktop" "${pkgdir}/usr/share/applications/appimagekit-wexond.desktop"
+ install -D -m755 "${srcdir}/wexond.sh" "${pkgdir}/usr/bin/wexond"
+ install -D -m755 "${srcdir}/wexond-${pkgver}.AppImage" "${pkgdir}/opt/appimages/wexond-${pkgver}.AppImage"
+ rm -r "${srcdir}/squashfs-root"
} \ No newline at end of file
diff --git a/wexond b/wexond.sh
index 5176cb9a4ba7..97b75907c669 100755
--- a/wexond
+++ b/wexond.sh
@@ -2,4 +2,4 @@
[ -z "$XDG_DATA_DIRS" ] && export XDG_DATA_DIRS=$HOME/.local/share:/usr/share
export APPIMAGE_SILENT_INSTALL=yes
-exec /opt/appimages/wexond-WEXOND_VERSION.AppImage --no-sandbox
+exec /opt/appimages/wexond-${pkgver}.AppImage --no-sandbox