summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d82ce68f224a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wezterm-nightly-bin
+ pkgdesc = Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust
+ pkgver = 20200517.122836.92c201c6.105.g5d508350
+ pkgrel = 1
+ url = https://wezfurlong.org/wezterm
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = fuse
+ depends = libx11
+ provides = wezterm
+ conflicts = wezterm-bin
+ options = !strip
+ source = wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage
+ source = LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = wezterm-nightly-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46c12c92bf16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Wez Furlong <wez at wezfurlong dot org>
+
+pkgname=wezterm-nightly-bin
+pkgver=20200517.122836.92c201c6.105.g5d508350
+pkgrel=1
+pkgdesc='Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust'
+arch=('i686' 'x86_64')
+url='https://wezfurlong.org/wezterm'
+license=('MIT')
+provides=('wezterm')
+# Don't strip: it will break the AppImage!
+options=('!strip')
+depends=('fuse' 'libx11')
+conflicts=('wezterm-bin')
+source=("wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage"
+ 'LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md')
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ chmod +x ${srcdir}/wezterm
+}
+
+pkgver() {
+ ${srcdir}/wezterm --version | cut -d' ' -f2 | tr - .
+}
+
+package() {
+ install -Dm755 wezterm -t "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}