summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD36
3 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 657ca31fd479..940a0dc12283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = whalebird-bin
- pkgdesc = An Electron based Mastodon client for Windows, Mac and Linux
+ pkgdesc = Electron based Mastodon client for Windows, Mac and Linux
pkgver = 4.1.3
- pkgrel = 1
- url = https://whalebird.org/
+ pkgrel = 2
+ url = https://whalebird.org
arch = x86_64
license = MIT
depends = c-ares
diff --git a/.gitignore b/.gitignore
index 01caf260c8dc..381b9eefbe6a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-pkg
-src
-*.pkg.*
-*.rpm
+*
+
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 573984bf1da5..20a0d8fbcd92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
-# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+
+
+pkgname=whalebird-bin
-_appname=whalebird
-pkgname="$_appname-bin"
pkgver=4.1.3
-pkgrel=1
-pkgdesc='An Electron based Mastodon client for Windows, Mac and Linux'
-arch=(x86_64)
-url='https://whalebird.org/'
-license=(MIT)
-depends=(c-ares ffmpeg gtk3 http-parser libevent libvpx libxslt libxss minizip nss re2 snappy libnotify libappindicator-gtk3)
-source=("https://github.com/h3poteto/whalebird-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
+pkgrel=2
+
+pkgdesc='Electron based Mastodon client for Windows, Mac and Linux'
+arch=('x86_64')
+url="https://${pkgname%-bin}.org"
+license=('MIT')
+
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
+
+source=("https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
sha256sums=('a661273879bbdded3b33e7d29dcc97b1eac87eaa8be72a372eb2128f7b69db40')
+
package() {
- mkdir -p "$pkgdir/usr/bin"
+ install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/${pkgname%-bin}/"
+ cp -R usr/share/* "$pkgdir/usr/share/"
cp -R opt "$pkgdir/"
- cp -R usr/share "$pkgdir/usr/"
- ln -s /opt/Whalebird/whalebird "$pkgdir/usr/bin/whalebird"
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/Whalebird/${pkgname%-bin}" "$pkgdir/usr/bin/"
}
+
+
+# vim: ts=2 sw=2 et ft=PKGBUILD: