summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dfa2ca49612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = whatip-git
+ pkgdesc = Info on your IP
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.gnome.org/gabmus/whatip
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = python
+ depends = libhandy
+ depends = python-requests
+ depends = python-pyroute2
+ depends = iproute2
+ depends = python-gobject
+ depends = gobject-introspection
+ provides = whatip
+ conflicts = whatip
+ source = whatip::git+https://gitlab.gnome.org/gabmus/whatip
+ sha256sums = SKIP
+
+pkgname = whatip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fe8f827a8bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/gabmus/whatip
+
+pkgname=whatip-git
+pkgver=c6d0337
+pkgrel=1
+pkgdesc='Info on your IP'
+arch=('any')
+url='https://gitlab.gnome.org/gabmus/whatip'
+license=('GPL3')
+depends=(
+ 'gtk3'
+ 'python'
+ 'libhandy'
+ 'python-requests'
+ 'python-pyroute2'
+ 'iproute2'
+ 'python-gobject'
+ 'gobject-introspection'
+)
+makedepends=('git' 'meson')
+provides=('whatip')
+conflicts=('whatip')
+source=("whatip::git+https://gitlab.gnome.org/gabmus/whatip")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/whatip"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/whatip"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --buildtype release ..
+ ninja
+}
+
+package() {
+ cd "$srcdir/whatip"
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}