summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.PKGINFO2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--generateAur.sh70
4 files changed, 73 insertions, 9 deletions
diff --git a/.PKGINFO b/.PKGINFO
index bde154f5690c..929e3a718a24 100644
--- a/.PKGINFO
+++ b/.PKGINFO
@@ -6,7 +6,7 @@ builddate = 1460577681
packager = whatsie
arch = x86_64
size = 140662880
-license =
+license = MIT
backup = etc/xdg/autostart/whatsie.desktop
depend = bash-completion
depend = desktop-file-utils
diff --git a/.SRCINFO b/.SRCINFO
index 99e8bc4f756c..136e25689c64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = whatsie
pkgver = 2.0.12
- pkgrel = 6
+ pkgrel = 7
arch = any
license = MIT
depends = dpkg
pkgname = whatsie
-
diff --git a/PKGBUILD b/PKGBUILD
index bee85c39270c..1b3b4612bf12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,7 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Michael Latman <mlatman@gmail.com>
pkgname=whatsie
pkgver=2.0.12
-pkgrel=6
+pkgrel=7
epoch=
pkgdesc="A simple & beautiful desktop client for WhatsApp Web."
arch=('any')
diff --git a/generateAur.sh b/generateAur.sh
new file mode 100644
index 000000000000..9f08dc4db952
--- /dev/null
+++ b/generateAur.sh
@@ -0,0 +1,70 @@
+pkgver=2.0.12
+pkgrel=7
+echo "# Maintainer: Michael Latman <mlatman@gmail.com>
+pkgname=whatsie
+pkgver=$pkgver
+pkgrel=$pkgrel
+epoch=
+pkgdesc=\"A simple & beautiful desktop client for WhatsApp Web.\"
+arch=('any')
+url=\"https://whatsie.chat\"
+license=('MIT')
+groups=()
+depends=(\"dpkg\")
+makedepends=()
+checkdepends=()
+optdepends=('lsb-release')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=\".INSTALL\"
+changelog=
+source=()
+noextract=()
+md5sums=()
+validpgpkeys=()
+package(){
+wget \"https://github.com/Aluxian/Whatsie/releases/download/v\$pkgver/whatsie-\$pkgver-linux-amd64.deb\" -P build_step/
+dpkg -x \"build_step/whatsie-\$pkgver-linux-amd64.deb\" \"\$pkgdir/\"
+
+}
+md5sums=()" > PKGBUILD
+
+
+echo "pkgname = whatsie
+pkgver = $pkgver
+pkgdesc = A simple & beautiful desktop client for WhatsApp Web.
+url = https://whatsie.chat
+builddate = 1460577681
+packager = whatsie
+arch = x86_64
+size = 140662880
+license = MIT
+backup = etc/xdg/autostart/whatsie.desktop
+depend = bash-completion
+depend = desktop-file-utils
+depend = gconf
+depend = gtk2
+depend = gvfs
+depend = hicolor-icon-theme
+depend = libcap
+depend = libgcrypt
+depend = libgcrypt11
+depend = libnotify
+depend = libsystemd
+depend = libxtst
+depend = nss
+depend = xdg-utils
+optdepend = gir1.2-gnomekeyring-1.0
+optdepend = libgnome-keyring
+optdepend = lsb-release" > .PKGINFO
+
+echo "pkgbase = whatsie
+ pkgver = $pkgver
+ pkgrel = $pkgrel
+ arch = any
+ license = MIT
+ depends = dpkg
+pkgname = whatsie" > .SRCINFO