summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--patch21
3 files changed, 36 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9be51c409fb..49700c2e32a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
-# Generated by mksrcinfo v8
-# Sun Dec 10 14:58:57 UTC 2017
pkgbase = whatweb-git
pkgdesc = Next generation web scanner that identifies what websites are running.
- pkgver = 4245.5aa3d5e4
+ pkgver = v0.4.9.r440.7885799c
pkgrel = 1
url = http://www.morningstarsecurity.com/research/whatweb
arch = i686
arch = x86_64
license = GPL
- depends = ruby1.8
+ depends = ruby
provides = whatweb
conflicts = whatweb
replaces = whatweb
source = whatweb::git://github.com/urbanadventurer/WhatWeb.git
+ source = patch
md5sums = SKIP
+ md5sums = 0de7ce37f82d813e06275f6e08a41fa1
pkgname = whatweb-git
diff --git a/PKGBUILD b/PKGBUILD
index af0f7bf0b79e..9303b59f1a84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=whatweb-git
-pkgver=4245.5aa3d5e4
+pkgver=v0.4.9.r440.7885799c
pkgrel=1
pkgdesc="Next generation web scanner that identifies what websites are running."
arch=('i686' 'x86_64')
@@ -10,20 +10,20 @@ conflicts=('whatweb')
provides=('whatweb')
url="http://www.morningstarsecurity.com/research/whatweb"
license=('GPL')
-depends=('ruby1.8')
-source=("whatweb::git://github.com/urbanadventurer/WhatWeb.git")
+depends=('ruby')
+source=("whatweb::git://github.com/urbanadventurer/WhatWeb.git"
+patch)
package() {
- cd whatweb
- sed -i 's/TODO //g' Makefile
- make DESTDIR=$pkgdir install
- sed 's#/usr/bin/env ruby#/usr/bin/ruby-1.8#g' -i ${pkgdir}/usr/bin/whatweb
-
+ cd whatweb
+ patch -Np1 -i ../patch
+ make DESTDIR=$pkgdir install
}
pkgver() {
- cd whatweb
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd whatweb
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-md5sums=('SKIP')
+md5sums=('SKIP'
+'0de7ce37f82d813e06275f6e08a41fa1')
diff --git a/patch b/patch
new file mode 100644
index 000000000000..4990174efc2a
--- /dev/null
+++ b/patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2019-06-30 21:53:44.499907157 +0200
++++ b/Makefile 2019-06-30 21:57:10.902605185 +0200
+@@ -17,7 +17,6 @@
+ cp -p -r my-plugins $(DESTDIR)$(LIBPATH)/$(NAME)/
+ cp -p -r plugins-disabled plugins lib plugin-development addons $(DESTDIR)$(LIBPATH)/$(NAME)/
+ cp -p -r CHANGELOG INSTALL LICENSE README.md whatweb.xsl $(DESTDIR)$(DOCPATH)/$(NAME)/
+- bundle install
+
+ clean:
+ # clean will remove your my-plugins folder. be warned
+--- a/whatweb 2019-06-30 21:53:44.766573026 +0200
++++ b/whatweb 2019-06-30 22:07:08.613968424 +0200
+@@ -34,7 +34,7 @@
+
+ $:.unshift(File.join(File.expand_path(File.dirname(__FILE__)), '.'))
+
+-require 'lib/whatweb'
++require '/usr/share/whatweb/lib/whatweb'
+
+ #
+ # Command-line usage information (full)