summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..745f279f8c3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 5.0.1
+# Tue Sep 20 11:07:55 UTC 2016
+pkgbase = whdd-git
+ pkgdesc = HDD diagnostic and recovery tool for Linux
+ pkgver = 2.2.r16.g5da4969
+ pkgrel = 1
+ url = https://github.com/whdd/whdd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = dialog
+ depends = ncurses
+ optdepends = smartmontools: for reading SMART attributes
+ provides = whdd
+ conflicts = whdd
+ source = git+https://github.com/whdd/whdd.git
+ md5sums = SKIP
+
+pkgname = whdd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdc3efa608c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natrio <natrio@list.ru>
+
+pkgname=whdd-git
+_pkgname=whdd
+pkgver=2.2.r16.g5da4969
+pkgrel=1
+pkgdesc='HDD diagnostic and recovery tool for Linux'
+url='https://github.com/whdd/whdd'
+arch=(i686 x86_64)
+license=(GPL)
+conflicts=(whdd)
+provides=(whdd)
+depends=(dialog ncurses)
+optdepends=('smartmontools: for reading SMART attributes')
+source=('git+https://github.com/whdd/whdd.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ IFS=- read _v _r < <(git describe)
+ echo "$_v.r${_r//-/.}"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 whdd "$pkgdir/usr/bin/whdd"
+}