summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70aa060d3057..2480672b38eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wiki-monkey
pkgdesc = Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version).
- pkgver = 5.4.0
- pkgrel = 2
+ pkgver = 5.5.0
+ pkgrel = 1
url = https://github.com/kynikos/wiki-monkey/wiki
arch = any
license = GPL3
@@ -12,8 +12,9 @@ pkgbase = wiki-monkey
depends = python-flask-cors
depends = python-flask-migrate
depends = python-marshmallow-sqlalchemy
- optdepends = python-pyopenssl: use ad-hoc SSL certificates instead of generating one
- source = https://files.pythonhosted.org/packages/source/w/wiki-monkey/wiki-monkey-5.4.0.tar.gz
- sha256sums = 9dc3b948bd965cb9620d7e0f16781de3d381e25133aacbec349faec48e7dd0db
+ optdepends = gunicorn: serve the application with a proper WSGI server instead of Flask's local development server
+ optdepends = python-pyopenssl: make Flask's local development server use ad-hoc SSL certificates instead of a permanent one
+ source = https://files.pythonhosted.org/packages/source/w/wiki-monkey/wiki-monkey-5.5.0.tar.gz
+ sha256sums = 65434a6f3a15264b4fe705acac39549a0c39df1adbd569ad3092f2906518827f
pkgname = wiki-monkey
diff --git a/PKGBUILD b/PKGBUILD
index ea2e80268292..f74aee826678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname='wiki-monkey'
# Don't use "-" in pkgver
-pkgver='5.4.0'
-pkgrel=2
+pkgver='5.5.0'
+pkgrel=1
pkgdesc="Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version)."
arch=('any')
url="https://github.com/kynikos/wiki-monkey/wiki"
@@ -15,10 +15,11 @@ depends=('python-configfile'
'python-flask-cors'
'python-flask-migrate' # implies 'python-flask-sqlalchemy'
'python-marshmallow-sqlalchemy')
-optdepends=('python-pyopenssl: use ad-hoc SSL certificates instead of generating one')
+optdepends=("gunicorn: serve the application with a proper WSGI server instead of Flask's local development server"
+ "python-pyopenssl: make Flask's local development server use ad-hoc SSL certificates instead of a permanent one")
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9dc3b948bd965cb9620d7e0f16781de3d381e25133aacbec349faec48e7dd0db')
+sha256sums=('65434a6f3a15264b4fe705acac39549a0c39df1adbd569ad3092f2906518827f')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"