summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b30ba1c60525..b43aa1ac4d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wiki-monkey
pkgdesc = Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version).
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
url = https://github.com/kynikos/wiki-monkey/wiki
arch = any
@@ -13,8 +13,8 @@ pkgbase = wiki-monkey
depends = python-flask-migrate
depends = python-marshmallow-sqlalchemy
optdepends = python-pyopenssl: use ad-hoc SSL certificates instead of generating one
- source = https://files.pythonhosted.org/packages/source/w/wiki-monkey/wiki-monkey-5.0.0.tar.gz
- sha256sums = 60144bef4a7a1caa08987949a2547bf7f42df948080dd349f76a5aaddc30605b
+ source = https://files.pythonhosted.org/packages/source/w/wiki-monkey/wiki-monkey-5.0.1.tar.gz
+ sha256sums = af55ae723a164c928dff628d503b1aaab460999a2c67ced8f80c5360b4e7d98a
pkgname = wiki-monkey
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index c00238755f1e..d3301d30ddde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='wiki-monkey'
# Don't use "-" in pkgver
-pkgver='5.0.0'
+pkgver='5.0.1'
pkgrel=1
pkgdesc="Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version)."
arch=('any')
@@ -11,14 +11,14 @@ license=('GPL3')
# Keep in sync with setup.py's install_requires option and requirements.txt
depends=('python-configfile'
'python-xdg'
- 'python-flask-restinpeace' # implies 'python-flask-marshmallow' and 'python-apispec'
+ 'python-flask-restinpeace' # implies 'python-flask-marshmallow', 'python-apispec' and 'python-apispec-webframeworks'
'python-flask-cors'
'python-flask-migrate' # implies 'python-flask-sqlalchemy'
'python-marshmallow-sqlalchemy')
optdepends=('python-pyopenssl: use ad-hoc SSL certificates instead of generating one')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('60144bef4a7a1caa08987949a2547bf7f42df948080dd349f76a5aaddc30605b')
+sha256sums=('af55ae723a164c928dff628d503b1aaab460999a2c67ced8f80c5360b4e7d98a')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"