summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b30ba1c60525
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wiki-monkey
+ pkgdesc = Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version).
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://github.com/kynikos/wiki-monkey/wiki
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-configfile
+ depends = python-xdg
+ depends = python-flask-restinpeace
+ depends = python-flask-cors
+ depends = python-flask-migrate
+ depends = python-marshmallow-sqlalchemy
+ optdepends = python-pyopenssl: use ad-hoc SSL certificates instead of generating one
+ source = https://files.pythonhosted.org/packages/source/w/wiki-monkey/wiki-monkey-5.0.0.tar.gz
+ sha256sums = 60144bef4a7a1caa08987949a2547bf7f42df948080dd349f76a5aaddc30605b
+
+pkgname = wiki-monkey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c00238755f1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='wiki-monkey'
+# Don't use "-" in pkgver
+pkgver='5.0.0'
+pkgrel=1
+pkgdesc="Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version)."
+arch=('any')
+url="https://github.com/kynikos/wiki-monkey/wiki"
+license=('GPL3')
+# Keep in sync with setup.py's install_requires option and requirements.txt
+depends=('python-configfile'
+ 'python-xdg'
+ 'python-flask-restinpeace' # implies 'python-flask-marshmallow' and 'python-apispec'
+ 'python-flask-cors'
+ 'python-flask-migrate' # implies 'python-flask-sqlalchemy'
+ 'python-marshmallow-sqlalchemy')
+optdepends=('python-pyopenssl: use ad-hoc SSL certificates instead of generating one')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('60144bef4a7a1caa08987949a2547bf7f42df948080dd349f76a5aaddc30605b')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}