summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--01-efireloc.diff14
-rw-r--r--PKGBUILD10
3 files changed, 4 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92657ac4c7d1..a4a653b3c13c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wimboot-git
pkgdesc = iPXE kernel to boot wim images from network for both UEFI and BIOS system
- pkgver = v2.6.0.r2.55cfe8a
+ pkgver = v2.6.0.r3.91be50c
pkgrel = 1
url = https://git.ipxe.org/wimboot.git
install = wimboot-git.install
@@ -12,9 +12,7 @@ pkgbase = wimboot-git
optdepends = ipxe-git: iPXE network boot program
optdepends = ipxe-netboot: Alternative iPXE network boot program, with Archlinux network install support
source = wimboot::git+https://git.ipxe.org/wimboot.git
- source = 01-efireloc.diff
sha256sums = SKIP
- sha256sums = 6f8184d75ff2c30a19f9192a8d6f159a390a677e6fd110fd4aea79ac14e9f31d
pkgname = wimboot-git
diff --git a/01-efireloc.diff b/01-efireloc.diff
deleted file mode 100644
index bf51cda2af97..000000000000
--- a/01-efireloc.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/efireloc.c b/src/efireloc.c
-index 519dd75..e0736cd 100644
---- a/src/efireloc.c
-+++ b/src/efireloc.c
-@@ -326,7 +326,8 @@ static void process_reloc ( bfd *bfd __unused, asection *section, arelent *rel,
- /* Generate a 2-byte PE relocation */
- generate_pe_reloc ( pe_reltab, offset, 2 );
- } else if ( ( strcmp ( howto->name, "R_386_PC32" ) == 0 ) ||
-- ( strcmp ( howto->name, "R_X86_64_PC32" ) == 0 ) ) {
-+ ( strcmp ( howto->name, "R_X86_64_PC32" ) == 0 ) ||
-+ ( strcmp ( howto->name, "R_X86_64_PLT32" ) == 0 ) ) {
- /* Skip PC-relative relocations; all relative offsets
- * remain unaltered when the object is loaded.
- */
diff --git a/PKGBUILD b/PKGBUILD
index 17b33f0fb6f3..4eeba5fb1b55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alif <alive4ever at live.com>
pkgname=wimboot-git
-pkgver=v2.6.0.r2.55cfe8a
+pkgver=v2.6.0.r3.91be50c
pkgrel=1
pkgdesc="iPXE kernel to boot wim images from network for both UEFI and BIOS system"
arch=(any)
@@ -10,10 +10,8 @@ makedepends=('git' 'pesign' 'gcab')
optdepends=("ipxe-git: iPXE network boot program"
"ipxe-netboot: Alternative iPXE network boot program, with Archlinux network install support")
install=$pkgname.install
-source=('wimboot::git+https://git.ipxe.org/wimboot.git'
- '01-efireloc.diff')
-sha256sums=('SKIP'
- '6f8184d75ff2c30a19f9192a8d6f159a390a677e6fd110fd4aea79ac14e9f31d')
+source=('wimboot::git+https://git.ipxe.org/wimboot.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -21,8 +19,6 @@ pkgver() {
}
build() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 < "$srcdir/01-efireloc.diff"
cd "$srcdir/${pkgname%-git}/src"
make
}