summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82e42e881a5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = win32pe
+ pkgdesc = C++ library for working with Win32 PE files
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://github.com/nathan-osman/win32pe
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = boost>=1.58
+ source = win32pe-0.1.0.tar.gz::https://github.com/nathan-osman/win32pe/archive/0.1.0.tar.gz
+ sha256sums = 479a8ca8b84c30ff0737d43ab0c80d843c1870d76e77186ad0034e2f9de9eb5e
+
+pkgname = win32pe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d545e1847f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nathan Osman <nathan@quickmediasolutions.com>
+
+pkgname='win32pe'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc="C++ library for working with Win32 PE files"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://github.com/nathan-osman/win32pe"
+makedepends=('cmake' 'boost>=1.58')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/nathan-osman/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('479a8ca8b84c30ff0737d43ab0c80d843c1870d76e77186ad0034e2f9de9eb5e')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file