summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a8a93c3cbee..836b5ff5e1e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = windscribe-git
- pkgdesc = Windscribe's GUI desktop client (git release)
+ pkgdesc = Windscribe's GUI desktop client
pkgver = 2.3.11_beta
pkgrel = 1
url = https://github.com/Windscribe/desktop-v2
@@ -27,7 +27,6 @@ pkgbase = windscribe-git
depends = desktop-file-utils
depends = icu67
provides = windscribe
- conflicts = windscribe-bin
source = desktop-v2::git+https://github.com/Windscribe/desktop-v2#branch=master
source = patch_installqt
source = patch_sourcechanges
diff --git a/PKGBUILD b/PKGBUILD
index 448ad685d594..63ff24e25b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=windscribe-git
pkgver=2.3.11_beta
pkgrel=1
-pkgdesc="Windscribe's GUI desktop client (git release)"
+pkgdesc="Windscribe's GUI desktop client"
arch=('x86_64')
url="https://github.com/Windscribe/desktop-v2"
license=('GPL2')
depends=('bash' 'iptables' 'procps-ng' 'qt5-base' 'hicolor-icon-theme' 'libnsl' 'curl' 'c-ares' 'qt5-svg' 'protobuf' 'desktop-file-utils' 'icu67')
makedepends=('git' 'python2' 'go' 'cmake' 'patchelf' 'dpkg' 'ruby' 'rpm-tools')
provides=('windscribe')
-conflicts=('windscribe-bin')
+# Conflicts commented out for now as there is not an official binary release yet
+# conflicts=('windscribe-bin')
install=${pkgname}.install
source=('desktop-v2::git+https://github.com/Windscribe/desktop-v2#branch=master' 'patch_installqt' 'patch_sourcechanges' 'patch_buildall')
sha512sums=('SKIP' 'f15f459d1bce294bbd706b07d040ec21eebfdc1cf71f3e384be9fe9ebf089b154d9e6528077e168db161e7ade945eaa1f9d6515aefc5490b1703bd8e1b13fdf8' '231765d8ebd14cccfc2a6f80c48672c3c8baa35101ee21c20c8d877955e23d3090856100fffd1964010344f3479e2fac8843301f315dc8d9a660fb97012a1481' '3d0f6e821967a3c639a86f511a06c321448730b1f485b0b9bf4597ca0a2538d8fa3fb383c9cd55862edbab959598994616e2ff1bb74c853214666870fda90e65')
@@ -35,11 +36,11 @@ prepare(){
cd "${srcdir}"/desktop-v2/tools
python bin/get-pip.py
python -m pip install -r requirements.txt
- cd "${srcdir}"/desktop-v2/tools/deps
}
build() {
# Need to figure out how to detect if certain modules were already made so that a re-compilation isn't needed
+ cd "${srcdir}"/desktop-v2/tools/deps
./'install_openssl'
./'install_qt'
./'install_cares'