summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--sample_c_lz-stub.patch37
3 files changed, 51 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95910112d51..a86ffd2799a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 14 15:17:08 UTC 2017
+# Sun Jun 18 19:20:02 UTC 2017
pkgbase = wine-gaming-nine
pkgdesc = Based off wine-staging, including the gallium-nine patches and some more hacks
pkgver = 2.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.wine-staging.com
arch = i686
arch = x86_64
@@ -140,21 +140,23 @@ pkgbase = wine-gaming-nine
options = staticlibs
options = !upx
source = https://github.com/wine-compholio/wine-patched/archive/staging-2.10.tar.gz
- source = https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-2.9.tar.gz
+ source = https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-2.10.tar.gz
source = https://github.com/wine-compholio/wine-staging/raw/master/patches/ntdll-Heap_FreeLists/0001-ntdll-Improve-heap-allocation-performance-by-using-m.patch
source = https://github.com/laino/wine-patches/archive/master.tar.gz
source = 30-win32-aliases.conf
source = gcc_7_fix.patch
source = keybindings.patch
+ source = sample_c_lz-stub.patch
source = steam.patch
source = wbemprox_query_v2.patch
sha1sums = 097e19e65873afe8be3ce877361b70bc5e423c25
- sha1sums = d587c2f35006c23b51836cbef0fb7b453130d59e
+ sha1sums = 9639666c62feddc12138791e43390bb15b3ba3fb
sha1sums = 0c45c2e050a7642acd5c7dec6fd5b03f8b5cd658
sha1sums = b9ca93f8afcd01cf12460d40022df733010069d2
sha1sums = 023a5c901c6a091c56e76b6a62d141d87cce9fdb
sha1sums = 0663651dd32b1537055bf560e6ec098623785238
sha1sums = f3febb8836f38320742a546c667106608d4c4395
+ sha1sums = f864ae0323f2196d143ee2f4b89e9312d9f0f65b
sha1sums = 74aae040fde9ff3c9e8da9c840557e87afdbc3a0
sha1sums = 644e141125a9f2407e64d23c85ec84a691c7caae
diff --git a/PKGBUILD b/PKGBUILD
index 56bcd55f907c..58563a6debf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@
# -Heap allocation perfomance improvement patch
# -Wbemprox videocontroller query fix v2 (see https://bugs.winehq.org/show_bug.cgi?id=38879 )
# -Steam patch, Crossover Hack version (see https://bugs.winehq.org/show_bug.cgi?id=39403 )
+# -sample_c_lz stub (see https://bugs.winehq.org/show_bug.cgi?id=42863 )
pkgname=wine-gaming-nine
pkgver=2.10
-pkgrel=1
+pkgrel=2
_pkgbasever=${pkgver/rc/-rc}
-#_d3d9ver=$_pkgbasever
-_d3d9ver=2.9
+_d3d9ver=$_pkgbasever
+#_d3d9ver=2.9
_winesrcdir="wine-patched-staging-$_pkgbasever"
source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbasever.tar.gz"
@@ -24,16 +25,18 @@ source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbas
30-win32-aliases.conf
gcc_7_fix.patch
keybindings.patch
+ sample_c_lz-stub.patch
steam.patch
wbemprox_query_v2.patch
)
sha1sums=('097e19e65873afe8be3ce877361b70bc5e423c25'
- 'd587c2f35006c23b51836cbef0fb7b453130d59e'
+ '9639666c62feddc12138791e43390bb15b3ba3fb'
'0c45c2e050a7642acd5c7dec6fd5b03f8b5cd658'
'b9ca93f8afcd01cf12460d40022df733010069d2'
'023a5c901c6a091c56e76b6a62d141d87cce9fdb'
'0663651dd32b1537055bf560e6ec098623785238'
'f3febb8836f38320742a546c667106608d4c4395'
+ 'f864ae0323f2196d143ee2f4b89e9312d9f0f65b'
'74aae040fde9ff3c9e8da9c840557e87afdbc3a0'
'644e141125a9f2407e64d23c85ec84a691c7caae'
)
@@ -150,6 +153,7 @@ prepare()
patch -p1 < ../wine-patches-master/0006-Ensure-16-byte-alignment-of-data.patch
patch -p1 < ../wbemprox_query_v2.patch
+ patch -p1 < ../sample_c_lz-stub.patch
patch -p1 -R < ../keybindings.patch
diff --git a/sample_c_lz-stub.patch b/sample_c_lz-stub.patch
new file mode 100644
index 000000000000..e5482074297d
--- /dev/null
+++ b/sample_c_lz-stub.patch
@@ -0,0 +1,37 @@
+--- a/dlls/wined3d/glsl_shader.c
++++ a/dlls/wined3d/glsl_shader.c
+@@ -91,6 +91,7 @@ struct glsl_sample_function
+ enum wined3d_data_type data_type;
+ BOOL output_single_component;
+ unsigned int offset_size;
++ BOOL disable_lod;
+ };
+
+ enum heap_node_op
+@@ -3420,6 +3421,17 @@ static void shader_glsl_get_sample_function(const struct wined3d_shader_context
+ const char *base = "texture", *type_part = "", *suffix = "";
+ unsigned int coord_size, deriv_size;
+
++ if (shadow && lod && resource_type == WINED3D_SHADER_RESOURCE_TEXTURE_2DARRAY)
++ {
++ FIXME("GLSL does not support sample comparison with lod for 2D array textures.\n");
++ lod = FALSE;
++ sample_function->disable_lod = TRUE;
++ }
++ else
++ {
++ sample_function->disable_lod = FALSE;
++ }
++
+ sample_function->data_type = ctx->reg_maps->resource_info[resource_idx].data_type;
+
+ if (resource_type >= ARRAY_SIZE(resource_type_info))
+@@ -3663,7 +3675,7 @@ static void PRINTF_ATTR(9, 10) shader_glsl_gen_sample_code(const struct wined3d_
+ }
+ if (dx && dy)
+ shader_addline(ins->ctx->buffer, ", %s, %s", dx, dy);
+- else if (bias)
++ else if (bias && !sample_function->disable_lod)
+ shader_addline(ins->ctx->buffer, ", %s", bias);
+ if (sample_function->offset_size)
+ {