summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5de1753364a8..007b8a05581d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-staging-git
pkgdesc = A compatibility layer for running Windows programs (staging branch, git version)
- pkgver = 4.20.r4.ga9639c41+wine.4.20.r74.ga9c4b309f6
+ pkgver = 5.3.r14.g5213d551+wine.5.3.r139.g4f53be1a6e
pkgrel = 1
url = https://www.wine-staging.com/
install = wine-staging-git.install
@@ -100,6 +100,8 @@ pkgbase = wine-staging-git
makedepends = lib32-gcc-libs
makedepends = libpcap
makedepends = lib32-libpcap
+ makedepends = faudio
+ makedepends = lib32-faudio
makedepends = desktop-file-utils
optdepends = giflib
optdepends = lib32-giflib
@@ -152,10 +154,10 @@ pkgbase = wine-staging-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=4.20.r74.ga9c4b309f6
- provides = wine-wow64=4.20.r74.ga9c4b309f6
- provides = wine-git=4.20.r74.ga9c4b309f6
- provides = wine-staging=4.20.r4.ga9639c41
+ provides = wine=5.3.r139.g4f53be1a6e
+ provides = wine-wow64=5.3.r139.g4f53be1a6e
+ provides = wine-git=5.3.r139.g4f53be1a6e
+ provides = wine-staging=5.3.r14.g5213d551
conflicts = wine
conflicts = wine-wow64
options = staticlibs
@@ -197,5 +199,7 @@ pkgname = wine-staging-git
depends = lib32-gcc-libs
depends = libpcap
depends = lib32-libpcap
+ depends = faudio
+ depends = lib32-faudio
depends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index fa64b929e100..80686e38590d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=wine-staging-git
-pkgver=4.20.r4.ga9639c41+wine.4.20.r74.ga9c4b309f6
+pkgver=5.3.r14.g5213d551+wine.5.3.r139.g4f53be1a6e
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
arch=('i686' 'x86_64')
@@ -22,6 +22,7 @@ _depends=(
'libsm' 'lib32-libsm'
'gcc-libs' 'lib32-gcc-libs'
'libpcap' 'lib32-libpcap'
+ 'faudio' 'lib32-faudio'
'desktop-file-utils'
)
makedepends=('git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex'
@@ -146,10 +147,10 @@ prepare() {
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
- # apply all wine-staging patches
+ # apply wine-staging patches (exclude xactengine-initial due to build error)
printf '%s\n' ' -> Applying wine-staging patches...'
cd "${srcdir}/wine-staging/patches"
- ./patchinstall.sh DESTDIR="${srcdir}/wine" --all
+ ./patchinstall.sh DESTDIR="${srcdir}/wine" --all -W xactengine-initial
}
pkgver() {