summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--wine-staging-pba.patch85
1 files changed, 60 insertions, 25 deletions
diff --git a/wine-staging-pba.patch b/wine-staging-pba.patch
index a63fea1c8971..48ce27df575e 100644
--- a/wine-staging-pba.patch
+++ b/wine-staging-pba.patch
@@ -1,5 +1,5 @@
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/buffer.c b/dlls/wined3d/buffer.c
---- a/dlls/wined3d/buffer.c 2018-03-31 12:50:14.767239563 +0200
+diff -r -u a/dlls/wined3d/buffer.c b/dlls/wined3d/buffer.c
+--- a/dlls/wined3d/buffer.c 2018-04-02 04:33:26.378794396 +0200
+++ b/dlls/wined3d/buffer.c 2018-03-31 12:48:20.431496034 +0200
@@ -28,12 +28,14 @@
#include "wined3d_private.h"
@@ -361,7 +361,7 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/buffer.c b/dlls
{
TRACE("Not creating a BO because GL_ARB_vertex_buffer is not supported.\n");
}
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/buffer_heap.c b/dlls/wined3d/buffer_heap.c
+diff -r -u a/dlls/wined3d/buffer_heap.c b/dlls/wined3d/buffer_heap.c
--- a/dlls/wined3d/buffer_heap.c 1970-01-01 01:00:00.000000000 +0100
+++ b/dlls/wined3d/buffer_heap.c 2018-03-31 12:48:20.432496032 +0200
@@ -0,0 +1,530 @@
@@ -896,8 +896,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/buffer_heap.c b
+ return WINED3D_OK;
+}
\ No newline at end of file
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/context.c b/dlls/wined3d/context.c
---- a/dlls/wined3d/context.c 2018-03-31 12:50:24.670217361 +0200
+diff -r -u a/dlls/wined3d/context.c b/dlls/wined3d/context.c
+--- a/dlls/wined3d/context.c 2018-04-02 04:33:36.094784165 +0200
+++ b/dlls/wined3d/context.c 2018-03-31 12:48:20.434496027 +0200
@@ -4956,7 +4956,11 @@
if (parameters->indexed)
@@ -912,8 +912,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/context.c b/dll
{
idx_data = index_buffer->resource.heap_memory;
}
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/cs.c b/dlls/wined3d/cs.c
---- a/dlls/wined3d/cs.c 2018-03-31 12:50:24.495217754 +0200
+diff -r -u a/dlls/wined3d/cs.c b/dlls/wined3d/cs.c
+--- a/dlls/wined3d/cs.c 2018-04-02 04:33:35.926784342 +0200
+++ b/dlls/wined3d/cs.c 2018-03-31 12:48:20.435496025 +0200
@@ -73,6 +73,7 @@
WINED3D_CS_OP_CLEAR_UNORDERED_ACCESS_VIEW,
@@ -1033,8 +1033,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/cs.c b/dlls/win
};
static BOOL wined3d_cs_st_check_space(struct wined3d_cs *cs, size_t size, enum wined3d_cs_queue_id queue_id)
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/device.c b/dlls/wined3d/device.c
---- a/dlls/wined3d/device.c 2018-03-31 12:50:24.718217254 +0200
+diff -r -u a/dlls/wined3d/device.c b/dlls/wined3d/device.c
+--- a/dlls/wined3d/device.c 2018-04-02 04:33:36.142784114 +0200
+++ b/dlls/wined3d/device.c 2018-03-31 12:48:20.438496018 +0200
@@ -840,6 +840,66 @@
device->null_sampler = NULL;
@@ -1119,8 +1119,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/device.c b/dlls
context_release(context);
}
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/directx.c b/dlls/wined3d/directx.c
---- a/dlls/wined3d/directx.c 2018-03-31 12:50:24.747217188 +0200
+diff -r -u a/dlls/wined3d/directx.c b/dlls/wined3d/directx.c
+--- a/dlls/wined3d/directx.c 2018-04-02 04:33:36.171784084 +0200
+++ b/dlls/wined3d/directx.c 2018-03-31 12:48:20.440496014 +0200
@@ -111,6 +111,7 @@
/* ARB */
@@ -1204,8 +1204,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/directx.c b/dll
{ARB_CLIP_CONTROL, MAKEDWORD_VERSION(4, 5)},
{ARB_CULL_DISTANCE, MAKEDWORD_VERSION(4, 5)},
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/Makefile.in b/dlls/wined3d/Makefile.in
---- a/dlls/wined3d/Makefile.in 2018-03-31 12:50:15.709237451 +0200
+diff -r -u a/dlls/wined3d/Makefile.in b/dlls/wined3d/Makefile.in
+--- a/dlls/wined3d/Makefile.in 2018-04-02 04:33:27.324793400 +0200
+++ b/dlls/wined3d/Makefile.in 2018-03-31 12:48:20.440496014 +0200
@@ -6,6 +6,7 @@
arb_program_shader.c \
@@ -1215,8 +1215,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/Makefile.in b/d
context.c \
cs.c \
device.c \
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/resource.c b/dlls/wined3d/resource.c
---- a/dlls/wined3d/resource.c 2018-03-31 12:50:24.426217908 +0200
+diff -r -u a/dlls/wined3d/resource.c b/dlls/wined3d/resource.c
+--- a/dlls/wined3d/resource.c 2018-04-02 04:33:35.852784420 +0200
+++ b/dlls/wined3d/resource.c 2018-03-31 12:48:20.440496014 +0200
@@ -340,6 +340,7 @@
HRESULT CDECL wined3d_resource_map(struct wined3d_resource *resource, unsigned int sub_resource_idx,
@@ -1261,8 +1261,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/resource.c b/dl
}
UINT CDECL wined3d_resource_update_info(struct wined3d_resource *resource, unsigned int sub_resource_idx,
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/state.c b/dlls/wined3d/state.c
---- a/dlls/wined3d/state.c 2018-03-31 12:50:24.522217693 +0200
+diff -r -u a/dlls/wined3d/state.c b/dlls/wined3d/state.c
+--- a/dlls/wined3d/state.c 2018-04-02 04:33:35.953784313 +0200
+++ b/dlls/wined3d/state.c 2018-03-31 12:48:20.442496009 +0200
@@ -4797,7 +4797,11 @@
else
@@ -1338,8 +1338,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/state.c b/dlls/
}
checkGLcall("bind constant buffers");
}
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/texture.c b/dlls/wined3d/texture.c
---- a/dlls/wined3d/texture.c 2018-03-31 12:50:24.445217866 +0200
+diff -r -u a/dlls/wined3d/texture.c b/dlls/wined3d/texture.c
+--- a/dlls/wined3d/texture.c 2018-04-02 04:33:35.873784397 +0200
+++ b/dlls/wined3d/texture.c 2018-03-31 12:48:20.443496007 +0200
@@ -2096,6 +2096,12 @@
static HRESULT texture_resource_sub_resource_map(struct wined3d_resource *resource, unsigned int sub_resource_idx,
@@ -1375,8 +1375,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/texture.c b/dll
};
/* Context activation is done by the caller. */
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/utils.c b/dlls/wined3d/utils.c
---- a/dlls/wined3d/utils.c 2018-03-31 12:50:24.671217359 +0200
+diff -r -u a/dlls/wined3d/utils.c b/dlls/wined3d/utils.c
+--- a/dlls/wined3d/utils.c 2018-04-02 04:33:36.095784164 +0200
+++ b/dlls/wined3d/utils.c 2018-03-31 12:48:20.445496003 +0200
@@ -6321,6 +6321,7 @@
LOCATION_TO_STR(WINED3D_LOCATION_DRAWABLE);
@@ -1386,8 +1386,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/utils.c b/dlls/
#undef LOCATION_TO_STR
if (location)
FIXME("Unrecognized location flag(s) %#x.\n", location);
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/wined3d_gl.h b/dlls/wined3d/wined3d_gl.h
---- a/dlls/wined3d/wined3d_gl.h 2018-03-31 12:50:24.279218237 +0200
+diff -r -u a/dlls/wined3d/wined3d_gl.h b/dlls/wined3d/wined3d_gl.h
+--- a/dlls/wined3d/wined3d_gl.h 2018-04-02 04:33:35.709784570 +0200
+++ b/dlls/wined3d/wined3d_gl.h 2018-03-31 12:48:20.449495993 +0200
@@ -44,6 +44,7 @@
/* ARB */
@@ -1405,8 +1405,8 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/wined3d_gl.h b/
ARB_MULTISAMPLE,
ARB_MULTITEXTURE,
ARB_OCCLUSION_QUERY,
-diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/wined3d_private.h b/dlls/wined3d/wined3d_private.h
---- a/dlls/wined3d/wined3d_private.h 2018-03-31 12:50:24.734217218 +0200
+diff -r -u a/dlls/wined3d/wined3d_private.h b/dlls/wined3d/wined3d_private.h
+--- a/dlls/wined3d/wined3d_private.h 2018-04-02 04:33:36.158784097 +0200
+++ b/dlls/wined3d/wined3d_private.h 2018-03-31 12:48:20.450495991 +0200
@@ -75,6 +75,7 @@
#define WINED3D_QUIRK_INFO_LOG_SPAM 0x00000080
@@ -1575,3 +1575,38 @@ diff -r -u '--exclude=*.orig' '--exclude=*.rej' a/dlls/wined3d/wined3d_private
};
static inline struct wined3d_buffer *buffer_from_resource(struct wined3d_resource *resource)
+diff -r -u wine/programs/winecfg/staging.c wine-patched/programs/winecfg/staging.c
+--- wine/programs/winecfg/staging.c 2018-04-02 04:33:35.679784602 +0200
++++ wine-patched/programs/winecfg/staging.c 2018-03-31 12:45:33.272871454 +0200
+@@ -35,14 +35,15 @@
+ */
+ static BOOL csmt_get(void)
+ {
+- WCHAR *buf = get_reg_key(config_key, "Direct3D", "csmt", NULL);
+- BOOL ret = buf ? !!*buf : TRUE;
+- HeapFree(GetProcessHeap(), 0, buf);
++ BOOL ret;
++ char *value = get_reg_key(config_key, keypath("DllRedirects"), "wined3d", NULL);
++ ret = (value && !strcmp(value, "wined3d-csmt.dll"));
++ HeapFree(GetProcessHeap(), 0, value);
+ return ret;
+ }
+ static void csmt_set(BOOL status)
+ {
+- set_reg_key_dword(config_key, "Direct3D", "csmt", status);
++ set_reg_key(config_key, keypath("DllRedirects"), "wined3d", status ? "wined3d-csmt.dll" : NULL);
+ }
+
+ /*
+diff -r -u wine/programs/winecfg/winecfg.rc wine-patched/programs/winecfg/winecfg.rc
+--- wine/programs/winecfg/winecfg.rc 2018-04-02 04:33:35.679784602 +0200
++++ wine-patched/programs/winecfg/winecfg.rc 2018-03-31 12:45:33.274871449 +0200
+@@ -315,7 +315,7 @@
+ BEGIN
+ GROUPBOX "Staging settings",IDC_STATIC,8,4,244,210
+ LTEXT "The following settings are experimental and may break stuff!\nMake sure to reset them again in case of a problem.",IDC_STATIC,16,16,230,16
+- CONTROL "Enable &CSMT for better graphic performance (deprecated)",IDC_ENABLE_CSMT,"Button",BS_AUTOCHECKBOX | WS_TABSTOP,16,40,230,8
++ CONTROL "Enable &CSMT for better graphic performance",IDC_ENABLE_CSMT,"Button",BS_AUTOCHECKBOX | WS_TABSTOP,16,40,230,8
+ CONTROL "Enable &VAAPI as backend for DXVA2 GPU decoding",IDC_ENABLE_VAAPI,"Button",BS_AUTOCHECKBOX | WS_TABSTOP,16,55,230,8
+ CONTROL "Enable Environmental Audio E&xtensions (EAX)",IDC_ENABLE_EAX,"Button",BS_AUTOCHECKBOX | WS_TABSTOP,16,70,230,8
+ CONTROL "&Hide Wine version from applications",IDC_ENABLE_HIDEWINE,"Button",BS_AUTOCHECKBOX | WS_TABSTOP,16,85,230,8