summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b2a24795989..c73660e504bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by makepkg 4.2.1
-# Sun Jun 14 11:08:13 UTC 2015
pkgbase = wineasio
pkgdesc = ASIO driver implementation for Wine
pkgver = 0.9.2
- pkgrel = 6
+ pkgrel = 7
url = http://sourceforge.net/projects/wineasio/
install = wineasio.install
arch = i686
@@ -14,7 +12,11 @@ pkgbase = wineasio
depends = wine
depends = jack
source = http://downloads.sourceforge.net/wineasio/wineasio-0.9.2.tar.gz
+ source = wineasio-fix-prep64bit.patch::https://github.com/jhernberg/wineasio/pull/1.patch
+ source = wineasio-fix-unicode-h.patch::https://github.com/jhernberg/wineasio/pull/10.patch
sha256sums = 9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b
+ sha256sums = 2789faed51992c6f6c1703cef8af3efdf26a3352bcef4b566de1979e69ab4b02
+ sha256sums = 3b9081fc015724ab0661269ed66832a3b019b21f5f2ebbadae304aa9c63a39a4
depends_x86_64 = lib32-jack
makedepends_x86_64 = gcc-multilib
diff --git a/PKGBUILD b/PKGBUILD
index 7f1e742f2757..6a7ec1662fd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Joakim Hernberg <jhernberg@alchemy.lu>
+# Author: Joakim Hernberg <jhernberg@alchemy.lu>
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
+# Maintainer: redtide <redtid3@gmail.com>
pkgname=wineasio
pkgver=0.9.2
-pkgrel=6
+pkgrel=7
pkgdesc="ASIO driver implementation for Wine"
url="http://sourceforge.net/projects/wineasio/"
@@ -18,18 +19,26 @@ makedepends_x86_64+=('gcc-multilib')
install="$pkgname".install
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b')
-
+source=(
+ "http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ "wineasio-fix-prep64bit.patch::https://github.com/jhernberg/wineasio/pull/1.patch"
+ "wineasio-fix-unicode-h.patch::https://github.com/jhernberg/wineasio/pull/10.patch"
+)
+sha256sums=(
+ '9fbc2d10a4cec307dc0558bed82b887c864424d16da40a80f1d80f907d92af0b'
+ '2789faed51992c6f6c1703cef8af3efdf26a3352bcef4b566de1979e69ab4b02'
+ '3b9081fc015724ab0661269ed66832a3b019b21f5f2ebbadae304aa9c63a39a4'
+)
prepare() {
cd "$pkgname"
cp /usr/include/steinberg-asio/asio.h asio.h
+ patch --forward --strip=1 --input="${srcdir}/wineasio-fix-unicode-h.patch"
if [[ "$CARCH" == x86_64 ]]; then
cp asio.h asio.h.i686
+ patch --forward --strip=1 --input="${srcdir}/wineasio-fix-prep64bit.patch"
./prepare_64bit_asio
fi
}
-
build() {
cd "$pkgname"
if [[ "$CARCH" == x86_64 ]]; then
@@ -42,7 +51,6 @@ build() {
make
fi
}
-
package() {
cd "$pkgname"
if [[ "$CARCH" == x86_64 ]]; then