summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a5398893c05..b5c31add8a61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Apr 18 15:46:28 UTC 2016
+# Mon Apr 25 16:57:36 UTC 2016
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
pkgver = 5.1.11.1
pkgrel = 1
- epoch = 1
+ epoch = 2
url = http://www.wingware.com
install = wingide.install
arch = i686
@@ -17,9 +17,13 @@ pkgbase = wingide
options = !strip
options = !emptydirs
source_i686 = http://wingware.com/pub/wingide/5.1.11/wingide-5.1.11-1-i386-linux.tar.gz
+ source_i686 = http://wingware.com/pub/wingide/5.1.11/patches/fix-autoclose-5.1.11p1-all.tar
md5sums_i686 = 392b8f3a0e2dcb69fd2d8316bd88b028
+ md5sums_i686 = fd1b66865a42b27fd6344b71e747c654
source_x86_64 = http://wingware.com/pub/wingide/5.1.11/wingide-5.1.11-1-x86_64-linux.tar.gz
+ source_x86_64 = http://wingware.com/pub/wingide/5.1.11/patches/fix-autoclose-5.1.11p1-all.tar
md5sums_x86_64 = ddacf06b4cc9577b9b80cbbb79de2d32
+ md5sums_x86_64 = fd1b66865a42b27fd6344b71e747c654
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 269e23b5ec38..95b48c0f01cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@ _wingver=5.1.11
_wingrel=1
pkgver=$_wingver.$_wingrel
pkgrel=1
-epoch=1 #bump this when adding a new patch
+epoch=2 #bump this when adding a new patch
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('i686' 'x86_64')
[ "$CARCH" = 'i686' ] && _pkgarch=i386
[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-#_wingpatch_x86_64=()
-#_wingpatch_i686=()
+_wingpatch_x86_64=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar")
+_wingpatch_i686=("fix-autoclose-5.1.11p1-all.tar" "fix-nonpy-indent-5.1.11p2-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
if [[ ! -z "$_wingpatch_x86_64" ]]; then
_wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
@@ -25,8 +25,10 @@ source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_
source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" $_wingpatch_i686)
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('392b8f3a0e2dcb69fd2d8316bd88b028')
-md5sums_x86_64=('ddacf06b4cc9577b9b80cbbb79de2d32')
+md5sums_i686=('392b8f3a0e2dcb69fd2d8316bd88b028'
+ 'fd1b66865a42b27fd6344b71e747c654')
+md5sums_x86_64=('ddacf06b4cc9577b9b80cbbb79de2d32'
+ 'fd1b66865a42b27fd6344b71e747c654')
install=${pkgname}.install
prepare() {