summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60a63a271994..032f629a0223 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.1.0.1.2
+ pkgver = 6.1.1.1.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -12,20 +12,8 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.1.0/wingide-6.1.0-1-x86_64-linux.tar.bz2
- source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p1-all.tar
- source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p2-all.tar
- source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-env-6.1.0p3-all.tar
- source = http://wingware.com/pub/wingide/6.1.0/patches/remote-replace-all-6.1.0p4-all.tar
- source = http://wingware.com/pub/wingide/6.1.0/patches/fix-sys-exit-reporting-6.1.0p5-all.tar
- source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pypath-expansion-6.1.0p6-all.tar
- md5sums = b4e5b7f9ec4be77e5e9e7e249b737b69
- md5sums = f96618da2fe8a5d12e90e0027a6e23f8
- md5sums = 45c443b9b1ef24be01139bb9e5610cfa
- md5sums = 0dca244c6e605d9b4e9cb9fa0eed5b96
- md5sums = 55b2b6f8ba70e5ee4146c0ec6cdefbe9
- md5sums = 5b26502347ddbd5d29f356389f848af3
- md5sums = 3a32eb00924f43f30c22a270e756c56a
+ source = http://wingware.com/pub/wingide/6.1.1/wingide-6.1.1-1-x86_64-linux.tar.bz2
+ md5sums = 44d38552af9d3d50ac6cae42a55426ac
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index f6a8e3c59a63..04a9e32dd9c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.1.0
+_wingver=6.1.1
_wingrel=1
-_wing_patch_lvl=2 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
@@ -11,19 +11,13 @@ url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar" "remote-replace-all-6.1.0p4-all.tar" "fix-sys-exit-reporting-6.1.0p5-all.tar" "fix-pypath-expansion-6.1.0p6-all.tar")
+#_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar" "remote-replace-all-6.1.0p4-all.tar" "fix-sys-exit-reporting-6.1.0p5-all.tar" "fix-pypath-expansion-6.1.0p6-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('b4e5b7f9ec4be77e5e9e7e249b737b69'
- 'f96618da2fe8a5d12e90e0027a6e23f8'
- '45c443b9b1ef24be01139bb9e5610cfa'
- '0dca244c6e605d9b4e9cb9fa0eed5b96'
- '55b2b6f8ba70e5ee4146c0ec6cdefbe9'
- '5b26502347ddbd5d29f356389f848af3'
- '3a32eb00924f43f30c22a270e756c56a')
+md5sums=('44d38552af9d3d50ac6cae42a55426ac')
install=${pkgname}.install