summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3218cd4a0bd7..48a6cdfa62c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 17 13:16:34 UTC 2017
+# Mon Nov 20 14:36:41 UTC 2017
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.0.7.1.23
+ pkgver = 6.0.8.2.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -14,20 +14,12 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.0.7/wingide-6.0.7-1-x86_64-linux.tar.bz2
- source = http://wingware.com/pub/wingide/6.0.7/patches/fix-vi-mark-ranges-6.0.7p1-all.tar
- source = http://wingware.com/pub/wingide/6.0.7/patches/remote-healing-6.0.7p2-all.tar
- source = http://wingware.com/pub/wingide/6.0.7/patches/optimize-recent-6.0.7p3-all.tar
- source = http://wingware.com/pub/wingide/6.0.7/patches/fix-exit-failure-6.0.7p6-all.tar
- source = http://wingware.com/pub/wingide/6.0.7/patches/fix-debug-stop-6.0.7p5-all.tar
- source = http://wingware.com/pub/wingide/6.0.7/patches/fix-auto-perspectives-6.0.7p4-all.tar
- md5sums = f3ed3fec851faab4ad3a9fe822151cfe
- md5sums = 3f173e4b04f7cfdab3dc66a8a54613b7
- md5sums = bd4739f28056900fd3c9797f43f6ee28
- md5sums = 47cc2e08696830188ba5ec145361e032
- md5sums = 84b4d1f65a60fb310e3caee093714e8e
- md5sums = af58e6f1e4a6c73d6062645a4db75ee7
- md5sums = dd54becbc042e853e27fc5a52bdce411
+ source = http://wingware.com/pub/wingide/6.0.8/wingide-6.0.8-2-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.0.8/patches/fix-remote-projects-6.0.8p2-all.tar
+ source = http://wingware.com/pub/wingide/6.0.8/patches/fix-remote-oscommands-6.0.8p3-all.tar
+ md5sums = 3077b5e5837f913e3c79551222fd2662
+ md5sums = bd4261a6629b7a43053f2fee24bdaffc
+ md5sums = d0660f788d0124a6b2eb8a85b0e9b7a7
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 9510a969dc5c..cfd5ce08ac93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.0.7
-_wingrel=1
-_wing_patch_lvl=23 #bump this when adding a patch
+_wingver=6.0.8
+_wingrel=2
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-vi-mark-ranges-6.0.7p1-all.tar" "remote-healing-6.0.7p2-all.tar" "optimize-recent-6.0.7p3-all.tar" "fix-exit-failure-6.0.7p6-all.tar" "fix-debug-stop-6.0.7p5-all.tar" "fix-auto-perspectives-6.0.7p4-all.tar")
+_wingpatch=("fix-remote-projects-6.0.8p2-all.tar" "fix-remote-oscommands-6.0.8p3-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('f3ed3fec851faab4ad3a9fe822151cfe'
- '3f173e4b04f7cfdab3dc66a8a54613b7'
- 'bd4739f28056900fd3c9797f43f6ee28'
- '47cc2e08696830188ba5ec145361e032'
- '84b4d1f65a60fb310e3caee093714e8e'
- 'af58e6f1e4a6c73d6062645a4db75ee7'
- 'dd54becbc042e853e27fc5a52bdce411')
+md5sums=('3077b5e5837f913e3c79551222fd2662'
+ 'bd4261a6629b7a43053f2fee24bdaffc'
+ 'd0660f788d0124a6b2eb8a85b0e9b7a7')
install=${pkgname}.install