summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b4db7855d16..ad5d377caafa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
pkgname=wingide
_wingver=6.0.5
_wingrel=1
-_wing_patch_lvl=1 #bump this when adding a patch
+_wing_patch_lvl=2 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-#_wingpatch=("")
+_wingpatch=("fix-auto-arg-removal-6.0.5p1-all.tar" "fix-script-print-encoding-6.0.5p2-all.tar" "fix-logging-6.0.5p3-all.tar" "fix-remote-bps-6.0.5p4-all.tar" "fix-vi-mode-yy-6.0.5p5-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('944c2edf81b7a681a9d0ab5dc528498c')
+md5sums=('944c2edf81b7a681a9d0ab5dc528498c'
+ '5c6ac15d903a67a3c2f62d8720ea7c25'
+ '25ae8c72354f4798c7bb871d45bedb37'
+ '117eec0e2ed0d062fcddbb9484170f53'
+ '3a841c186a0c1f850acd5463c2f612b8'
+ 'aa5edf6eb1259b04def4a989632cf2ca')
install=${pkgname}.install