summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad476e4b12a5..60a63a271994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.1.0.1.1
+ pkgver = 6.1.0.1.2
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -16,10 +16,16 @@ pkgbase = wingide
source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p1-all.tar
source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-6.1.0p2-all.tar
source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pep8-env-6.1.0p3-all.tar
+ source = http://wingware.com/pub/wingide/6.1.0/patches/remote-replace-all-6.1.0p4-all.tar
+ source = http://wingware.com/pub/wingide/6.1.0/patches/fix-sys-exit-reporting-6.1.0p5-all.tar
+ source = http://wingware.com/pub/wingide/6.1.0/patches/fix-pypath-expansion-6.1.0p6-all.tar
md5sums = b4e5b7f9ec4be77e5e9e7e249b737b69
md5sums = f96618da2fe8a5d12e90e0027a6e23f8
md5sums = 45c443b9b1ef24be01139bb9e5610cfa
md5sums = 0dca244c6e605d9b4e9cb9fa0eed5b96
+ md5sums = 55b2b6f8ba70e5ee4146c0ec6cdefbe9
+ md5sums = 5b26502347ddbd5d29f356389f848af3
+ md5sums = 3a32eb00924f43f30c22a270e756c56a
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 4650c4dbe85f..f6a8e3c59a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wingide
_wingver=6.1.0
_wingrel=1
-_wing_patch_lvl=1 #bump this when adding a patch
+_wing_patch_lvl=2 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
@@ -11,7 +11,7 @@ url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar")
+_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar" "remote-replace-all-6.1.0p4-all.tar" "fix-sys-exit-reporting-6.1.0p5-all.tar" "fix-pypath-expansion-6.1.0p6-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
@@ -20,7 +20,10 @@ options=(!strip !emptydirs)
md5sums=('b4e5b7f9ec4be77e5e9e7e249b737b69'
'f96618da2fe8a5d12e90e0027a6e23f8'
'45c443b9b1ef24be01139bb9e5610cfa'
- '0dca244c6e605d9b4e9cb9fa0eed5b96')
+ '0dca244c6e605d9b4e9cb9fa0eed5b96'
+ '55b2b6f8ba70e5ee4146c0ec6cdefbe9'
+ '5b26502347ddbd5d29f356389f848af3'
+ '3a32eb00924f43f30c22a270e756c56a')
install=${pkgname}.install