summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0fe7c381f58..3eef06f3e9e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Dec 22 18:26:16 UTC 2015
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 5.1.8
+ pkgver = 5.1.8.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -14,9 +16,13 @@ pkgbase = wingide
options = !strip
options = !emptydirs
source_i686 = http://wingware.com/pub/wingide/5.1.8/wingide-5.1.8-1-i386-linux.tar.gz
+ source_i686 = http://wingware.com/pub/wingide/5.1.8/patches/fix-run-as-pkg-module-5.1.8p1-all.tar
md5sums_i686 = a8960c2099f86e4385985e49ca05dfcf
+ md5sums_i686 = 377ca1633a9bbfaf46dda934ea52a8f5
source_x86_64 = http://wingware.com/pub/wingide/5.1.8/wingide-5.1.8-1-x86_64-linux.tar.gz
+ source_x86_64 = http://wingware.com/pub/wingide/5.1.8/patches/fix-run-as-pkg-module-5.1.8p1-all.tar
md5sums_x86_64 = 7038e5dc3e73fe30aa1098622a1a3616
+ md5sums_x86_64 = 377ca1633a9bbfaf46dda934ea52a8f5
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 6aecbf900b03..f19deda37d27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,42 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-pkgver=5.1.8
+_wingver=5.1.8
+_wingrel=1
+pkgver=$_wingver.$_wingrel
pkgrel=1
-_pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('i686' 'x86_64')
[ "$CARCH" = 'i686' ] && _pkgarch=i386
[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-source_x86_64=("http://wingware.com/pub/$pkgname/$pkgver/$pkgname-$pkgver-$_pkgrel-x86_64-linux.tar.gz")
-source_i686=("http://wingware.com/pub/$pkgname/$pkgver/$pkgname-$pkgver-$_pkgrel-i386-linux.tar.gz")
+_wingpatch_x86_64=("fix-run-as-pkg-module-5.1.8p1-all.tar")
+_wingpatch_i686=("fix-run-as-pkg-module-5.1.8p1-all.tar")
+_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
+if [[ ! -z "$_wingpatch_x86_64" ]]; then
+ _wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
+fi
+if [[ ! -z "$_wingpatch_i686" ]]; then
+ _wingpatch_i686=( "${_wingpatch_i686[@]/#/$_patch_url_prefix}" )
+fi
+source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.gz" $_wingpatch_x86_64)
+source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" $_wingpatch_i686)
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('a8960c2099f86e4385985e49ca05dfcf')
-md5sums_x86_64=('7038e5dc3e73fe30aa1098622a1a3616')
+md5sums_i686=('a8960c2099f86e4385985e49ca05dfcf'
+ '377ca1633a9bbfaf46dda934ea52a8f5')
+md5sums_x86_64=('7038e5dc3e73fe30aa1098622a1a3616'
+ '377ca1633a9bbfaf46dda934ea52a8f5')
install=${pkgname}.install
prepare() {
- cd "$srcdir/$pkgname-$pkgver-$_pkgrel-$_pkgarch-linux"
+ cd "$srcdir/$pkgname-$_wingver-$_wingrel-$_pkgarch-linux"
sed -i 's/python/python2/' wing-install.py
}
package() {
- cd "$srcdir/$pkgname-$pkgver-$_pkgrel-$_pkgarch-linux"
+ cd "$srcdir/$pkgname-$_wingver-$_wingrel-$_pkgarch-linux"
./wing-install.py \
--install-binary \
--winghome "${pkgdir}/opt/${pkgname}" \
@@ -39,6 +51,11 @@ package() {
# Fix a bug in the script
sed -i "s|'x86_64'\]|'x86_64' \]|" ${pkgdir}/opt/wingide/run-wing.sh
+ # Copy over patch (if any)
+ if [ -d ../patches ]; then
+ cp -r ../patches ${pkgdir}/opt/${pkgname}/.
+ fi
+
# Correct the file permissions
chown -R root:root "${pkgdir}/opt/${pkgname}"
chmod +x ${pkgdir}/opt/${pkgname}/resources/linux/desktop/install-linux-desktop.sh