summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5734d73a4cb..6505e40d7043 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 12 16:53:51 UTC 2017
+# Thu Mar 23 09:32:23 UTC 2017
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.0.2.1.3
+ pkgver = 6.0.3.1.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -14,20 +14,10 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.0.2/wingide-6.0.2-1-x86_64-linux.tar.bz2
- source = http://wingware.com/pub/wingide/6.0.2/patches/fix-debug-ipython-6.0.2p6-all.tar
- source = http://wingware.com/pub/wingide/6.0.2/patches/fix-cpu-usage-6.0.2p5-all.tar
- source = http://wingware.com/pub/wingide/6.0.2/patches/fix-none-module-6.0.2p4-all.tar
- source = http://wingware.com/pub/wingide/6.0.2/patches/dont-fill-database-6.0.2p3-all.tar
- source = http://wingware.com/pub/wingide/6.0.2/patches/fix-remote-debug-6.0.2p1-all.tar
- source = http://wingware.com/pub/wingide/6.0.2/patches/py3-pi-files-6.0.2p2-linux64.tar
- md5sums = e3d7ba6435b747ac348166d7db5aef00
- md5sums = 2b0b5360a808e675dbd367ce68a20c04
- md5sums = 30fa111b03ed2582872b10132cf232b5
- md5sums = d534f8fc73390b92fa0f30dbe4da626e
- md5sums = b084f0bdbc2f4c250683f776f29d0ebc
- md5sums = 18df10d42f3e7befd012db2c41c5a03f
- md5sums = 03046d03198fe1535e24735ef6a8bd0e
+ source = http://wingware.com/pub/wingide/6.0.3/wingide-6.0.3-1-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.0.3/patches/fix-keyboard-open-6.0.3p1-all.tar
+ md5sums = 302f28233292611419c2f36b44b7ee83
+ md5sums = c0dd3a668f4353c720bcbfed485a5646
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index fcfccef105b4..126e7f4b0c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.0.2
+_wingver=6.0.3
_wingrel=1
-_wing_patch_lvl=3 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-debug-ipython-6.0.2p6-all.tar" "fix-cpu-usage-6.0.2p5-all.tar" "fix-none-module-6.0.2p4-all.tar" "dont-fill-database-6.0.2p3-all.tar" "fix-remote-debug-6.0.2p1-all.tar" "py3-pi-files-6.0.2p2-linux64.tar")
+_wingpatch=("fix-keyboard-open-6.0.3p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('e3d7ba6435b747ac348166d7db5aef00'
- '2b0b5360a808e675dbd367ce68a20c04'
- '30fa111b03ed2582872b10132cf232b5'
- 'd534f8fc73390b92fa0f30dbe4da626e'
- 'b084f0bdbc2f4c250683f776f29d0ebc'
- '18df10d42f3e7befd012db2c41c5a03f'
- '03046d03198fe1535e24735ef6a8bd0e')
+md5sums=('302f28233292611419c2f36b44b7ee83'
+ 'c0dd3a668f4353c720bcbfed485a5646')
install=${pkgname}.install