summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 032f629a0223..269d5ab890d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingide
pkgdesc = Wing IDE Professional is the full-featured Python IDE for professional programmers.
- pkgver = 6.1.1.1.1
+ pkgver = 6.1.2.1.1
pkgrel = 1
url = http://www.wingware.com
install = wingide.install
@@ -12,8 +12,14 @@ pkgbase = wingide
depends = xdg-utils
options = !strip
options = !emptydirs
- source = http://wingware.com/pub/wingide/6.1.1/wingide-6.1.1-1-x86_64-linux.tar.bz2
- md5sums = 44d38552af9d3d50ac6cae42a55426ac
+ source = http://wingware.com/pub/wingide/6.1.2/wingide-6.1.2-1-x86_64-linux.tar.bz2
+ source = http://wingware.com/pub/wingide/6.1.2/patches/fix-new-venv-6.1.2p1-all.tar
+ source = http://wingware.com/pub/wingide/6.1.2/patches/fix-goto-defn-6.1.2p4-all.tar
+ source = http://wingware.com/pub/wingide/6.1.2/patches/fix-activation-6.1.2p2-all.tar
+ md5sums = c64255d62885498ac20513cafd7527c3
+ md5sums = cf1a2166c7a3605264d22269b346fb7d
+ md5sums = d691d2b46be9d0723b2c9742b89f9506
+ md5sums = 67f6cf80f5b8031a6ace081b38e28286
pkgname = wingide
diff --git a/PKGBUILD b/PKGBUILD
index 04a9e32dd9c5..cd26b6af9f8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=6.1.1
+_wingver=6.1.2
_wingrel=1
_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
@@ -11,13 +11,16 @@ url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-#_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar" "remote-replace-all-6.1.0p4-all.tar" "fix-sys-exit-reporting-6.1.0p5-all.tar" "fix-pypath-expansion-6.1.0p6-all.tar")
+_wingpatch=("fix-new-venv-6.1.2p1-all.tar" "fix-goto-defn-6.1.2p4-all.tar" "fix-activation-6.1.2p2-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums=('44d38552af9d3d50ac6cae42a55426ac')
+md5sums=('c64255d62885498ac20513cafd7527c3'
+ 'cf1a2166c7a3605264d22269b346fb7d'
+ 'd691d2b46be9d0723b2c9742b89f9506'
+ '67f6cf80f5b8031a6ace081b38e28286')
install=${pkgname}.install