summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221e795a03bc..77143339b662 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Mon May 1 16:18:53 UTC 2017
+# Tue Apr 3 09:12:42 UTC 2018
pkgbase = wingpanel-indicator-bluetooth-git
pkgdesc = Bluetooth indicator for Wingpanel
- pkgver = r111.0c3df8d
+ pkgver = r184.23e33e8
pkgrel = 1
url = https://github.com/elementary/wingpanel-indicator-bluetooth
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
makedepends = intltool
+ makedepends = meson
makedepends = vala
makedepends = wingpanel-git
depends = bluez
diff --git a/PKGBUILD b/PKGBUILD
index ae87b5042175..83543a17261b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-indicator-bluetooth-git
-pkgver=r111.0c3df8d
+pkgver=r184.23e33e8
pkgrel=1
pkgdesc='Bluetooth indicator for Wingpanel'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('bluez' 'glib2' 'glibc' 'gtk3' 'libgee'
'libwingpanel-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'intltool' 'vala' 'wingpanel-git')
+makedepends=('git' 'granite-git' 'intltool' 'meson' 'vala' 'wingpanel-git')
provides=('wingpanel-indicator-bluetooth')
conflicts=('wingpanel-indicator-bluetooth')
source=('git+https://github.com/elementary/wingpanel-indicator-bluetooth.git')
@@ -23,8 +23,6 @@ pkgver() {
}
prepare() {
- cd wingpanel-indicator-bluetooth
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -32,20 +30,16 @@ prepare() {
}
build() {
- cd wingpanel-indicator-bluetooth/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='OFF'
- make
+ cd build
+
+ arch-meson ../wingpanel-indicator-bluetooth
+ ninja
}
package() {
- cd wingpanel-indicator-bluetooth/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: