summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD44
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07edcb4a2d95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sat Aug 20 21:20:50 UTC 2016
+pkgbase = wingpanel-indicator-sound
+ pkgdesc = Sound indicator for Wingpanel
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://launchpad.net/wingpanel-indicator-sound
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = GPL3
+ makedepends = cmake
+ makedepends = gobject-introspection
+ makedepends = gtk2
+ makedepends = vala
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libcanberra
+ depends = libgee
+ depends = libnotify
+ depends = libpulse
+ depends = libgranite.so
+ depends = libwingpanel-2.0.so
+ source = https://launchpad.net/wingpanel-indicator-sound/loki/2.0/+download/wingpanel-indicator-sound-2.0.tar.xz
+ sha256sums = 00f4bd8d6b0da96fd0509d76ccad530f185753eb01d7ab5e7ab7baf22bd47d7f
+
+pkgname = wingpanel-indicator-sound
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..3c88c053a36e
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('wingpanel-indicator-sound')
+builddeps=('gala-bzr' 'wingpanel')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eea6243b081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=wingpanel-indicator-sound
+pkgver=2.0
+pkgrel=1
+pkgdesc='Sound indicator for Wingpanel'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/wingpanel-indicator-sound'
+license=('GPL3')
+groups=('pantheon')
+depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libcanberra' 'libgee'
+ 'libnotify' 'libpulse'
+ 'libgranite.so' 'libwingpanel-2.0.so')
+makedepends=('cmake' 'gobject-introspection' 'gtk2' 'vala')
+source=("https://launchpad.net/wingpanel-indicator-sound/loki/${pkgver}/+download/wingpanel-indicator-sound-${pkgver}.tar.xz")
+sha256sums=('00f4bd8d6b0da96fd0509d76ccad530f185753eb01d7ab5e7ab7baf22bd47d7f')
+
+prepare() {
+ cd wingpanel-indicator-sound-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd wingpanel-indicator-sound-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='FALSE'
+ make
+}
+
+package() {
+ cd wingpanel-indicator-sound-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: