summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
-rw-r--r--fix-libdir.patch10
3 files changed, 4 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2c5057e2def..a2abcb76a7ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
pkgver = r349.a437def
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/elementary/wingpanel
arch = i686
arch = x86_64
@@ -46,7 +46,6 @@ pkgbase = wingpanel-standalone-git
source = minus-gala.patch
source = y-is-broken-cogl.patch
source = autohide.patch
- source = fix-libdir.patch
sha256sums = SKIP
sha256sums = 37b3853f5e8a84a4d86c392beb0b422e03c71c7c53519f49883bfa5550979ae8
sha256sums = e56bc3b154539b6ae2ca7494f46f6f68c55f167b73203b92d645839bf8e9a5ea
diff --git a/PKGBUILD b/PKGBUILD
index 3014f6664baf..90416d5e93c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wingpanel-standalone-git
pkgver=r349.a437def
-pkgrel=1
+pkgrel=2
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
url='https://github.com/elementary/wingpanel'
@@ -27,8 +27,7 @@ source=('git+https://github.com/elementary/wingpanel.git'
'minus-galaplugin.patch'
'minus-gala.patch'
'y-is-broken-cogl.patch'
- 'autohide.patch'
- 'fix-libdir.patch')
+ 'autohide.patch')
sha256sums=('SKIP'
'37b3853f5e8a84a4d86c392beb0b422e03c71c7c53519f49883bfa5550979ae8'
'e56bc3b154539b6ae2ca7494f46f6f68c55f167b73203b92d645839bf8e9a5ea'
@@ -59,10 +58,6 @@ prepare() {
msg2 "Remove Gala dependency"
patch -Np2 < ../minus-gala.patch
- #Fix broken libdir in pkgconfig
- msg2 "Remove Gala dependency"
- patch -Np2 < ../fix-libdir.patch
-
#Cogl can't be found when not using gala's cmake package; wtf?
msg2 "Remove CoglFixes (broken)"
patch -Np2 < ../y-is-broken-cogl.patch
@@ -79,7 +74,7 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DCMAKE_INSTALL_LIBDIR='lib' \
-DGSETTINGS_COMPILE='FALSE'
make
}
diff --git a/fix-libdir.patch b/fix-libdir.patch
deleted file mode 100644
index 59ac9bfcef25..000000000000
--- a/fix-libdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/wingpanel/lib/wingpanel.pc.cmake 2018-04-26 00:08:18.601484341 +0900
-+++ src/wingpanel/lib/wingpanel.pc.cmake~ 2018-04-26 00:01:01.562507883 +0900
-@@ -1,6 +1,6 @@
- prefix=@PREFIX@
- exec_prefix=${prefix}
--libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
-+libdir=@CMAKE_INSTALL_LIBDIR@
- includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
- indicatorsdir=${libdir}/wingpanel
-