summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--autohide.patch25
-rw-r--r--minus-backgroundmanager.patch2
4 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84bcb187b0f2..887db7aec42c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
- pkgver = r413.b6811e8
+ pkgver = r419.1df4fc3
pkgrel = 1
url = https://github.com/elementary/wingpanel
arch = i686
@@ -8,10 +8,10 @@ pkgbase = wingpanel-standalone-git
groups = pantheon-qq
license = GPL3
makedepends = meson
+ makedepends = libgranite.so
makedepends = git
makedepends = vala
depends = libgee
- depends = libgranite.so
depends = libwnck3
depends = cogl
optdepends = pantheon-applications-menu-git: Application launcher
@@ -47,9 +47,9 @@ pkgbase = wingpanel-standalone-git
source = autohide.patch
source = reverse-105c1d0.patch
sha256sums = SKIP
- sha256sums = ab49041873724b299131e6d6f59ff20cbfd1c48b9cd61bbac4ab16cc005d0f1a
+ sha256sums = 7131827bd4ea454eecc389f372450a9f1a795ead12b91ab629324b9efc5cfb04
sha256sums = aa0a27e41df60a7b15e2fd7e0d06551663b98917b7632e4067e6b9a39407de1c
- sha256sums = 1d5ccfa659b0e63637a8a84adbbf1fb104a3f9ca565755f13ec89ed7e9073384
+ sha256sums = f1ebada8f241bb714007470f99c0e7a3b1a9dda35b7d2996644b493b93ab1243
sha256sums = 53bfa2220d14065ca848c36217abe812685c7d6e0d42251423d0faa2a0ac5394
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index c0d12f8130e5..d98d40b0f8f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-standalone-git
-pkgver=r413.b6811e8
+pkgver=r419.1df4fc3
pkgrel=1
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
url='https://github.com/elementary/wingpanel'
license=('GPL3')
groups=('pantheon-qq')
-depends=(lib{gee,granite.so,wnck3} 'cogl')
-makedepends=('meson' 'git' 'vala')
+depends=(lib{gee,wnck3} 'cogl')
+makedepends=('meson' 'libgranite.so' 'git' 'vala')
optdepends=("pantheon-applications-menu-git: Application launcher"
wingpanel-indicator-{a11y,bluetooth,datetime,keyboard,network,notifications,power,session,sensors,sound}-git": Tray applet"
wingpanel-indicator-{ayatana,namarupa}-git": Display Unity 7 tray applets"
@@ -26,9 +26,9 @@ source=('git+https://github.com/elementary/wingpanel.git'
'autohide.patch'
'reverse-105c1d0.patch')
sha256sums=('SKIP'
- 'ab49041873724b299131e6d6f59ff20cbfd1c48b9cd61bbac4ab16cc005d0f1a'
+ '7131827bd4ea454eecc389f372450a9f1a795ead12b91ab629324b9efc5cfb04'
'aa0a27e41df60a7b15e2fd7e0d06551663b98917b7632e4067e6b9a39407de1c'
- '1d5ccfa659b0e63637a8a84adbbf1fb104a3f9ca565755f13ec89ed7e9073384'
+ 'f1ebada8f241bb714007470f99c0e7a3b1a9dda35b7d2996644b493b93ab1243'
'53bfa2220d14065ca848c36217abe812685c7d6e0d42251423d0faa2a0ac5394')
pkgver() {
diff --git a/autohide.patch b/autohide.patch
index 64f1485f06d4..81456b76bb32 100644
--- a/autohide.patch
+++ b/autohide.patch
@@ -52,7 +52,7 @@ diff --git a/./src/PanelWindow.vala b/./src/PanelWindow.vala
index 162c54a..e06472f 100644
--- a/./src/PanelWindow.vala
+++ b/./src/PanelWindow.vala
-@@ -29,6 +29,13 @@ public class Wingpanel.PanelWindow : Gtk.Window {
+@@ -29,6 +29,14 @@ public class Wingpanel.PanelWindow : Gtk.Window {
private int panel_height;
private bool expanded = false;
private int panel_displacement;
@@ -60,20 +60,19 @@ index 162c54a..e06472f 100644
+ private uint timeout;
+ private bool hiding = false;
+ private bool delay = false;
-+ private string autohide = "Disabled";
-+ private int autohide_delay = 200;
++ private static GLib.Settings panel_settings = new GLib.Settings ("io.elementary.desktop.wingpanel");
++ private string autohide_mode = panel_settings.get_string ("autohide");
++ private int autohide_delay = panel_settings.get_int ("delay");
+ private Wnck.Screen wnck_screen = Wnck.Screen.get_default ();
public PanelWindow (Gtk.Application application) {
Object (
-@@ -70,16 +77,67 @@ public class Wingpanel.PanelWindow : Gtk.Window {
+@@ -70,16 +77,65 @@ public class Wingpanel.PanelWindow : Gtk.Window {
application.add_accelerator ("<Control>Tab", "app.cycle", null);
application.add_accelerator ("<Control><Shift>Tab", "app.cycle-back", null);
-+ var panel_settings = new GLib.Settings ("io.elementary.desktop.wingpanel");
-+
+ panel_settings.changed["autohide"].connect (() => {
-+ autohide = panel_settings.get_string ("autohide");
++ autohide_mode = panel_settings.get_string ("autohide");
+ update_autohide_mode ();
+ });
+
@@ -102,9 +101,9 @@ index 162c54a..e06472f 100644
+ }
+ panel_displacement++;
+ } else {
-+ if (panel_displacement <= panel_height * (-1)) {
++ if (panel_displacement <= panel_height * -1) {
+ timeout = 0;
-+ switch (autohide) {
++ switch (autohide_mode) {
+ case "Autohide":
+ update_struts ();
+ this.leave_notify_event.connect (hide_panel);
@@ -138,11 +137,13 @@ index 162c54a..e06472f 100644
update_panel_dimensions ();
return true;
-@@ -90,7 +146,128 @@ public class Wingpanel.PanelWindow : Gtk.Window {
+@@ -90,7 +146,130 @@ public class Wingpanel.PanelWindow : Gtk.Window {
Services.BackgroundManager.initialize (this.monitor_number, panel_height);
- Timeout.add (300 / panel_height, animation_step);
++ panel_displacement--;
++ update_panel_dimensions ();
+ update_autohide_mode ();
+ }
+
@@ -223,7 +224,7 @@ index 162c54a..e06472f 100644
+ this.enter_notify_event.disconnect (show_panel);
+ this.motion_notify_event.disconnect (show_panel);
+ hiding = false;
-+ if (autohide != "Disabled") {
++ if (autohide_mode != "Disabled") {
+ if (delay) {
+ Thread.usleep (autohide_delay * 1000);
+ }
@@ -235,7 +236,7 @@ index 162c54a..e06472f 100644
+ }
+
+ private void update_autohide_mode () {
-+ switch (autohide) {
++ switch (autohide_mode) {
+ case "Autohide":
+ case "Float":
+ delay = true;
diff --git a/minus-backgroundmanager.patch b/minus-backgroundmanager.patch
index 33c34f4108b6..b1cb8c844e14 100644
--- a/minus-backgroundmanager.patch
+++ b/minus-backgroundmanager.patch
@@ -45,7 +45,7 @@
static construct {
resource_provider = new Gtk.CssProvider ();
- resource_provider.load_from_resource ("io/elementary/wingpanel/application.css");
+ resource_provider.load_from_resource ("io/elementary/wingpanel/panel.css");
- }
-
- public override bool button_press_event (Gdk.EventButton event) {