summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--fix-libdir.patch10
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e143bc104b54..c2c5057e2def 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
- pkgver = r346.61c4f9f
+ pkgver = r349.a437def
pkgrel = 1
url = https://github.com/elementary/wingpanel
arch = i686
@@ -46,12 +46,14 @@ pkgbase = wingpanel-standalone-git
source = minus-gala.patch
source = y-is-broken-cogl.patch
source = autohide.patch
+ source = fix-libdir.patch
sha256sums = SKIP
sha256sums = 37b3853f5e8a84a4d86c392beb0b422e03c71c7c53519f49883bfa5550979ae8
sha256sums = e56bc3b154539b6ae2ca7494f46f6f68c55f167b73203b92d645839bf8e9a5ea
sha256sums = 47934e9aff119cedcfe7d184078ad60d3d715e07f1ca7cb1715e50b2e0c517e8
sha256sums = b1902c1d44ac546df63cd0224a7d2ef2cb6394ca556512c30c370d387db7bbab
sha256sums = da77ed83459b7d49056f35b9de1dd8b487b3c51234911f43b2fa401a38b6dd4a
+ sha256sums = f94a739163a8974f86271e65bbfb5272d81ff64162d7743174c7441834c3dc88
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index b2f512cc138d..3014f6664baf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-standalone-git
-pkgver=r346.61c4f9f
+pkgver=r349.a437def
pkgrel=1
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
@@ -27,13 +27,15 @@ source=('git+https://github.com/elementary/wingpanel.git'
'minus-galaplugin.patch'
'minus-gala.patch'
'y-is-broken-cogl.patch'
- 'autohide.patch')
+ 'autohide.patch'
+ 'fix-libdir.patch')
sha256sums=('SKIP'
'37b3853f5e8a84a4d86c392beb0b422e03c71c7c53519f49883bfa5550979ae8'
'e56bc3b154539b6ae2ca7494f46f6f68c55f167b73203b92d645839bf8e9a5ea'
'47934e9aff119cedcfe7d184078ad60d3d715e07f1ca7cb1715e50b2e0c517e8'
'b1902c1d44ac546df63cd0224a7d2ef2cb6394ca556512c30c370d387db7bbab'
- 'da77ed83459b7d49056f35b9de1dd8b487b3c51234911f43b2fa401a38b6dd4a')
+ 'da77ed83459b7d49056f35b9de1dd8b487b3c51234911f43b2fa401a38b6dd4a'
+ 'f94a739163a8974f86271e65bbfb5272d81ff64162d7743174c7441834c3dc88')
pkgver() {
cd wingpanel
@@ -57,6 +59,10 @@ prepare() {
msg2 "Remove Gala dependency"
patch -Np2 < ../minus-gala.patch
+ #Fix broken libdir in pkgconfig
+ msg2 "Remove Gala dependency"
+ patch -Np2 < ../fix-libdir.patch
+
#Cogl can't be found when not using gala's cmake package; wtf?
msg2 "Remove CoglFixes (broken)"
patch -Np2 < ../y-is-broken-cogl.patch
diff --git a/fix-libdir.patch b/fix-libdir.patch
new file mode 100644
index 000000000000..59ac9bfcef25
--- /dev/null
+++ b/fix-libdir.patch
@@ -0,0 +1,10 @@
+--- src/wingpanel/lib/wingpanel.pc.cmake 2018-04-26 00:08:18.601484341 +0900
++++ src/wingpanel/lib/wingpanel.pc.cmake~ 2018-04-26 00:01:01.562507883 +0900
+@@ -1,6 +1,6 @@
+ prefix=@PREFIX@
+ exec_prefix=${prefix}
+-libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
++libdir=@CMAKE_INSTALL_LIBDIR@
+ includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
+ indicatorsdir=${libdir}/wingpanel
+