summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--autohide-evbox.patch4
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48e540bd0aba..fd94c6f9ddf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 30 10:18:18 UTC 2017
+# Wed May 31 04:23:58 UTC 2017
pkgbase = wingpanel-standalone-git
pkgdesc = Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)
- pkgver = r286.89956c5
- pkgrel = 3
+ pkgver = r288.0b6d486
+ pkgrel = 1
url = https://github.com/elementary/wingpanel
arch = i686
arch = x86_64
@@ -53,7 +53,7 @@ pkgbase = wingpanel-standalone-git
sha256sums = 1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95
sha256sums = 910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d
sha256sums = df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced
- sha256sums = e57f3eb84a91f36ce673aa76fae9b28ecee41a34a451492fc0a78cd2c48b5c6b
+ sha256sums = e6655f2a5dd2215dd2380ad728510aacde10c5fe29dff4ff5c9711a787c737c5
pkgname = wingpanel-standalone-git
diff --git a/PKGBUILD b/PKGBUILD
index fc9405e7bfe0..fa942a2da8de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=wingpanel-standalone-git
-pkgver=r286.89956c5
-pkgrel=3
+pkgver=r288.0b6d486
+pkgrel=1
pkgdesc='Stylish top panel that holds indicators and spawns an application launcher (without Gala dependencies)'
arch=('i686' 'x86_64')
url='https://github.com/elementary/wingpanel'
@@ -33,7 +33,7 @@ sha256sums=('SKIP'
'1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95'
'910130e7033db8874ed8d5e1734c6eb0ce75eed7ddf2620400c2a129cf05755d'
'df03ebb7fe08da77d51e6b96ab033b5c712530727d9fa2dd61420d2c7923fced'
- 'e57f3eb84a91f36ce673aa76fae9b28ecee41a34a451492fc0a78cd2c48b5c6b')
+ 'e6655f2a5dd2215dd2380ad728510aacde10c5fe29dff4ff5c9711a787c737c5')
pkgver() {
cd wingpanel
@@ -54,16 +54,16 @@ prepare() {
patch -Np2 < ../minus-backgroundmanager.patch
msg2 "minus gpg"
patch -Np2 < ../minus-galaplugin.patch
- msg2 "minus gcm"
- patch -Np2 < ../minus-gala-cmake.patch
+ #msg2 "minus gcm"
+ #patch -Np2 < ../minus-gala-cmake.patch
#autohide
- msg2 "autohide"
- patch -Np2 < ../autohide-evbox.patch
+ #msg2 "autohide"
+ #patch -Np2 < ../autohide-evbox.patch
#Cogl can't be found, although it is installed. Arch-specific? .so bump?
- msg2 "minus cgl"
- patch -Np2 < ../y-is-broken-cogl.patch
+ #msg2 "minus cgl"
+ #patch -Np2 < ../y-is-broken-cogl.patch
}
build() {
diff --git a/autohide-evbox.patch b/autohide-evbox.patch
index 5eb47946a9b3..301096269880 100644
--- a/autohide-evbox.patch
+++ b/autohide-evbox.patch
@@ -49,7 +49,7 @@
return true;
}
-@@ -85,7 +106,25 @@
+@@ -85,7 +106,27 @@
//Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
@@ -70,6 +70,8 @@
+ private bool reactivate () {
+ animate_panel ();
+
++ //Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
++
+ Timeout.add (100 / panel_height, animation_step);
+
+ return true;