summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 4 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1df27a69bdde..a93cfa190412 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = wings3d
arch = x86_64
arch = i686
license = GPL
+ makedepends = setconf
+ makedepends = gendesk
depends = esdl
optdepends = povray: rendering support via POV-Ray
optdepends = kerkythea: rendering support via Kerkythea
diff --git a/PKGBUILD b/PKGBUILD
index e87944565341..ada42c78874b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ arch=('x86_64' 'i686')
url="http://www.wings3d.com/"
license=('GPL')
depends=('esdl')
+makedepends=('setconf' 'gendesk')
optdepends=('povray: rendering support via POV-Ray'
'kerkythea: rendering support via Kerkythea')
replaces=('wings' 'wings-devel')
@@ -26,6 +27,7 @@ _genericname=('3D Modeler')
build() {
cd "$srcdir"
gendesk
+ setconf "$pkgname.desktop" Categories "Graphics;3DGraphics;"
cd "$_pkgname-$pkgver"
export ESDL_PATH=$(echo /usr/lib/erlang/lib/esdl-*)