summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--wings3d.install21
3 files changed, 18 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81ed1226310e..1df27a69bdde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = wings3d
arch = x86_64
arch = i686
license = GPL
- depends = esdl>=1.0.1
+ depends = esdl
optdepends = povray: rendering support via POV-Ray
optdepends = kerkythea: rendering support via Kerkythea
replaces = wings
@@ -15,10 +15,8 @@ pkgbase = wings3d
source = http://downloads.sourceforge.net/wings/wings-1.4.1.tar.bz2
source = wings3d
source = wings3d.png
- source = wings3d.install
- md5sums = f62a06acdbf2d4ef09ce2bf55e8cec0f
- md5sums = 62fd2b01d06b88b64d6ea4f043c6cc48
- md5sums = 150ee5b1b9b44e20862210c9b01e53f4
- md5sums = fe97a01e5f683b08eb8079120117d94e
+ sha256sums = 51aea431e18935e5634ea673caa945f586db2203855554d8dcab5e9545f2789a
+ sha256sums = 46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e
+ sha256sums = ad49fded5e503131ee0e2e03a6db0974aa60f50e1ec6cd697fcacef126c40f52
pkgname = wings3d
diff --git a/PKGBUILD b/PKGBUILD
index e1118610bd51..e87944565341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,17 +10,17 @@ pkgdesc="3D modeling program"
arch=('x86_64' 'i686')
url="http://www.wings3d.com/"
license=('GPL')
-depends=('esdl>=1.0.1')
+depends=('esdl')
optdepends=('povray: rendering support via POV-Ray'
'kerkythea: rendering support via Kerkythea')
replaces=('wings' 'wings-devel')
-install=wings3d.install
-source=(http://downloads.sourceforge.net/wings/${_pkgname}-${pkgver}.tar.bz2
- wings3d wings3d.png wings3d.install)
-md5sums=('f62a06acdbf2d4ef09ce2bf55e8cec0f'
- '62fd2b01d06b88b64d6ea4f043c6cc48'
- '150ee5b1b9b44e20862210c9b01e53f4'
- 'fe97a01e5f683b08eb8079120117d94e')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/wings/$_pkgname-$pkgver.tar.bz2"
+ "$pkgname"
+ "$pkgname.png")
+sha256sums=('51aea431e18935e5634ea673caa945f586db2203855554d8dcab5e9545f2789a'
+ '46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e'
+ 'ad49fded5e503131ee0e2e03a6db0974aa60f50e1ec6cd697fcacef126c40f52')
_genericname=('3D Modeler')
build() {
diff --git a/wings3d.install b/wings3d.install
index 74ac0797d3ac..98f3ea19007a 100644
--- a/wings3d.install
+++ b/wings3d.install
@@ -1,23 +1,14 @@
-post_install() {
- echo "update desktop mime database..."
- update-desktop-database
-}
-
post_upgrade() {
- echo "update desktop mime database..."
- update-desktop-database
+ #gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor
+ update-desktop-database -q
}
-pre_remove() {
- /bin/true
+post_install() {
+ post_upgrade
}
post_remove() {
- echo "update desktop mime database..."
- update-desktop-database
+ post_upgrade
}
-op=$1
-shift
-
-$op "$@"
+# vim:set ts=2 sw=2 et: