summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--0000-sysmacros.patch10
-rw-r--r--PKGBUILD37
3 files changed, 43 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f77dd0f3842e..0e7cf5d63bb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
-# Generated by mksrcinfo v8
-# Sun Jul 3 16:47:18 UTC 2016
pkgbase = wipefreespace
- pkgdesc = Securely wipe the free space on an ext2/3/4,NTFS, XFS,ReiserFSv3, ReiserFSv4, FAT12/16/32,Minix,JFS and HFS+ partition or drive
- pkgver = 2.2
+ pkgdesc = Securely wipe the free space on an ext2/3/4,NTFS, XFS, ReiserFSv3, ReiserFSv4, FAT12/16/32, Minix, JFS and HFS+ partition or drive
+ pkgver = 2.6
pkgrel = 1
- url = https://wipefreespace.sourceforge.net/
+ url = https://sourceforge.net/projects/wipefreespace
arch = i686
arch = x86_64
license = GPL
- source = http://downloads.sourceforge.net/project/wipefreespace/wipefreespace/2.2/wipefreespace-2.2.tar.gz
- sha256sums = 676c1de1c06a1da43ac8cb5b4bb2082867cef29a0377a3a74d889b4e0459eb61
+ source = https://downloads.sourceforge.net/project/wipefreespace/wipefreespace/2.6/wipefreespace-2.6.tar.gz
+ source = 0000-sysmacros.patch
+ md5sums = 7e52f8f44ebca3d89af7148de87d5139
+ md5sums = fb1e4e01526cdfa3f853e2b2b99b71f1
+ sha256sums = 3ede8c0d0f704896cbe2d5bfa9c913a45b2f13d15d5c8929fd09a761295647f3
+ sha256sums = 500c4e1fa566be22e3b07e1bcf0a36b0f18d8f46ac9922e603e1a42edb2b7902
pkgname = wipefreespace
-
diff --git a/0000-sysmacros.patch b/0000-sysmacros.patch
new file mode 100644
index 000000000000..c4dd4be01fd9
--- /dev/null
+++ b/0000-sysmacros.patch
@@ -0,0 +1,10 @@
+--- src/wfs_util.c.orig 2018-01-02 15:27:53.000000000 -0500
++++ src/wfs_util.c 2019-08-04 19:53:05.301455493 -0400
+@@ -123,6 +123,7 @@
+ #ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h> /* for open() */
+ #endif
++#include <sys/sysmacros.h>
+
+ #ifdef HAVE_SYS_STAT_H
+ # include <sys/stat.h>
diff --git a/PKGBUILD b/PKGBUILD
index 478d7379a62f..5b36bfd653b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,48 @@
set -u
pkgname='wipefreespace'
-pkgver=2.2
-pkgrel=1
-pkgdesc='Securely wipe the free space on an ext2/3/4,NTFS, XFS,ReiserFSv3, ReiserFSv4, FAT12/16/32,Minix,JFS and HFS+ partition or drive'
+pkgver='2.6'
+pkgrel='1'
+pkgdesc='Securely wipe the free space on an ext2/3/4,NTFS, XFS, ReiserFSv3, ReiserFSv4, FAT12/16/32, Minix, JFS and HFS+ partition or drive'
arch=('i686' 'x86_64')
-url='https://wipefreespace.sourceforge.net/'
+url='https://sourceforge.net/projects/wipefreespace'
license=('GPL')
-_verwatch=('https://sourceforge.net/projects/wipefreespace/rss' ".*<title>.*/${pkgname}-\([0-9\.]\+\)\.tar\.gz\].*" 'f')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('676c1de1c06a1da43ac8cb5b4bb2082867cef29a0377a3a74d889b4e0459eb61')
+_verwatch=("${url}/rss" ".*<title>.*/${pkgname}-\([0-9\.]\+\)\.tar\.gz\].*" 'f')
+source=(
+ "https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ '0000-sysmacros.patch'
+)
+md5sums=('7e52f8f44ebca3d89af7148de87d5139'
+ 'fb1e4e01526cdfa3f853e2b2b99b71f1')
+sha256sums=('3ede8c0d0f704896cbe2d5bfa9c913a45b2f13d15d5c8929fd09a761295647f3'
+ '500c4e1fa566be22e3b07e1bcf0a36b0f18d8f46ac9922e603e1a42edb2b7902')
prepare() {
set -u
cd "${pkgbase}-${pkgver}"
- CFLAGS="${CFLAGS} -Wno-unused-result" \
- ./configure --prefix='/usr'
- echo '#define HAVE_LINUX_LOOP_H 1' >> 'config.h'
+
+ # diff -pNau3 src/wfs_util.c{.orig,} > '0000-sysmacros.patch'
+ patch -Nbup0 -i "${srcdir}/0000-sysmacros.patch"
+
set +u
}
build() {
set -u
cd "${pkgbase}-${pkgver}"
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
- make -s -j "${_nproc}"
+ if [ ! -s 'Makefile' ]; then
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ ./configure --prefix='/usr'
+ echo '#define HAVE_LINUX_LOOP_H 1' >> 'config.h'
+ fi
+ make -s
set +u
}
package () {
set -u
cd "${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make -j1 DESTDIR="${pkgdir}" install
set +u
}
set +u