summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD45
-rw-r--r--wids.default3
-rw-r--r--wireless-ids.install8
-rw-r--r--wireless-ids.service17
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a84cbf81e82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Nov 29 23:11:48 UTC 2017
+pkgbase = wireless-ids-git
+ pkgdesc = The Exploit Database (EDB) an ultimate archive of exploits and vulnerable software - A collection of hacks
+ pkgver = 24.b132071
+ pkgrel = 1
+ url = https://github.com/SYWorks/wireless-ids
+ install = wireless-ids.install
+ arch = any
+ license = custom
+ depends = python2
+ depends = aircrack-ng
+ depends = wireshark-cli
+ depends = mlocate
+ options = !strip
+ source = git+https://github.com/SYWorks/wireless-ids.git
+ source = wids.default
+ source = wireless-ids.service
+ sha256sums = SKIP
+ sha256sums = 6eb645517297a7131f2a5a1c57ce239c885db11261ff0c87cac97e6e503505a1
+ sha256sums = 09d6ac0003650d5b6b4cca37d216a33469bde4f9b099c5e74628b59973055aa9
+
+pkgname = wireless-ids-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3451e1c1a7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+pkgname="wireless-ids-git"
+_gitname="wireless-ids"
+pkgver=24.b132071
+pkgrel=1
+pkgdesc="The Exploit Database (EDB) an ultimate archive of exploits and vulnerable software - A collection of hacks"
+url="https://github.com/SYWorks/wireless-ids"
+license=("custom")
+arch=('any')
+depends=('python2' 'aircrack-ng' 'wireshark-cli' 'mlocate')
+options=('!strip')
+source=("git+https://github.com/SYWorks/${_gitname}.git" "wids.default" "wireless-ids.service")
+sha256sums=('SKIP'
+ '6eb645517297a7131f2a5a1c57ce239c885db11261ff0c87cac97e6e503505a1'
+ '09d6ac0003650d5b6b4cca37d216a33469bde4f9b099c5e74628b59973055aa9')
+install=${_gitname}.install
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s" "${ver//-/.}"
+}
+
+build(){
+ cd "${srcdir}/${_gitname}"
+ sed -i '1s/python/python2/' "wids.py"
+ python2 -m compileall *.py
+}
+
+package() {
+ cd "${srcdir}"
+ # The database
+ #chmod -R 644 "$srcdir/${_gitname}"
+ #chmod -R a+X "$srcdir/${_gitname}"
+ install -dm 755 "$pkgdir/usr/share"
+ cp -r "$srcdir/${_gitname}" "$pkgdir/usr/share/${_gitname}"
+ rm -rf "$pkgdir/usr/share/${_gitname}/.git"
+ chmod +x "${pkgdir}/usr/share/wireless-ids/wids.py"
+
+ #and now for .service file
+ install -Dm644 wireless-ids.service "${pkgdir}/usr/lib/systemd/system/wireless-ids.service"
+ install -Dm644 wids.default "${pkgdir}/etc/default/wids"
+}
+
diff --git a/wids.default b/wids.default
new file mode 100644
index 000000000000..f76de658c5dd
--- /dev/null
+++ b/wids.default
@@ -0,0 +1,3 @@
+# Default Config for wireless intrusion Detection system
+
+LOGFILE=/var/log/wids.log
diff --git a/wireless-ids.install b/wireless-ids.install
new file mode 100644
index 000000000000..b512d9b95dc0
--- /dev/null
+++ b/wireless-ids.install
@@ -0,0 +1,8 @@
+post_install(){
+ echo "test"
+ ln -s "/usr/share/wireless-ids/wids.py" "/usr/bin/wids.py"
+}
+
+pre_remove(){
+ unlink "/usr/bin/wids.py"
+}
diff --git a/wireless-ids.service b/wireless-ids.service
new file mode 100644
index 000000000000..970ef97b2625
--- /dev/null
+++ b/wireless-ids.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Wireless Intrusion Detection Service
+After=network.target
+
+[Service]
+Type=simple
+EnvironmentFile=-/etc/default/wids
+ExecStart=/usr/share/wireless-ids/wids.py >> $LOGFILE
+Restart=always
+RestartSec=1
+User=root
+Group=root
+TimeoutSec=15
+
+[Install]
+WantedBy=multi-user.target
+