summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD93
-rw-r--r--wireshark.desktop10
-rw-r--r--wireshark.pngbin18535 -> 0 bytes
4 files changed, 73 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6145d9acc961..a997e0f6be23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,43 @@
+# Generated by mksrcinfo v8
+# Tue Nov 8 16:04:44 UTC 2016
pkgbase = wireshark-git
pkgdesc = A free network protocol analyzer for Unix/Linux. GIT version
- pkgver = 51933.b2689ab
+ pkgver = 2.3.0rc0+1430+g7531318
pkgrel = 1
- url = http://www.wireshark.org/
+ url = https://www.wireshark.org/
install = wireshark-git.install
arch = i686
arch = x86_64
license = GPL2
+ makedepends = cmake
makedepends = git
- depends = gtk3
- depends = libpcap
- depends = gnutls
+ makedepends = ninja
+ makedepends = python
depends = c-ares
- depends = e2fsprogs
- depends = lua
- depends = portaudio
depends = geoip
- depends = libsmi
+ depends = glib2
+ depends = libpcap
+ depends = lua52
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = gnutls
depends = krb5
- depends = perl-parse-yapp
- depends = python2
+ depends = nghttp2
+ depends = sbc
+ depends = snappy
+ depends = lz4
+ depends = libssh
provides = wireshark
+ conflicts = wireshark-common
conflicts = wireshark-gtk
+ conflicts = wireshark-qt
+ conflicts = wireshark-cli
replaces = ethereal
- options = strip
- options = !libtool
- source = wireshark.desktop
- source = wireshark.png
- source = wireshark::git+https://code.wireshark.org/git/wireshark
- sha1sums = dd9b14967b1ab16d6bd75af4ea790df50a8e397e
- sha1sums = d57aa736a9864a2ed518aec4f463f3bb30a5edd5
- sha1sums = SKIP
+ source = git+https://code.wireshark.org/git/wireshark
+ sha256sums = SKIP
pkgname = wireshark-git
diff --git a/PKGBUILD b/PKGBUILD
index 85358ecd507e..e257df4a9abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,69 @@
-# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Maintainer: Peter Wu <peter@lekensteyn.nl>
+# Contributor: Daniel Nagy <danielnagy at gmx de>
pkgname=wireshark-git
-pkgver=51933.b2689ab
+pkgver=2.3.0rc0+1430+g7531318
pkgrel=1
pkgdesc="A free network protocol analyzer for Unix/Linux. GIT version"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('gtk3' 'libpcap' 'gnutls' 'c-ares' 'e2fsprogs' 'lua' 'portaudio' 'geoip' 'libsmi'
- 'krb5' 'perl-parse-yapp' 'python2')
-makedepends=('git')
-url="http://www.wireshark.org/"
-sha1sums=('dd9b14967b1ab16d6bd75af4ea790df50a8e397e'
- 'd57aa736a9864a2ed518aec4f463f3bb30a5edd5'
- 'SKIP')
+depends=(
+ 'c-ares'
+ 'geoip'
+ 'glib2'
+ 'libpcap'
+ 'lua52'
+
+ # wireshark-qt dependencies
+ 'qt5-multimedia'
+ 'qt5-svg'
+ 'qt5-tools'
+ # wireshark-gtk (deprecated) depedencies
+ #'portaudio'
+ # shared between the GUI (for post-installation hook)
+ 'desktop-file-utils'
+ 'hicolor-icon-theme'
+
+ # optional dependencies for improved dissection or features
+ 'gnutls' # for SSL decryption using RSA keys
+ 'krb5'
+ #'libsmi'
+ 'nghttp2' # for HTTP/2 dissector
+ 'sbc' # Bluetooth audio codec
+ 'snappy' 'lz4' # for cql dissector
+
+ # extcap (sshdump, etc.)
+ 'libssh'
+ )
+# perl-parse-yapp is only needed as build-time dependency if you are actually
+# going to regenerate pidl dissectors (unlikely for the majority of users).
+makedepends=('cmake' 'git' 'ninja' 'python')
+url="https://www.wireshark.org/"
+source=("git+https://code.wireshark.org/git/wireshark")
+sha256sums=('SKIP')
replaces=('ethereal')
provides=('wireshark')
-_gitmod='wireshark'
-source=("wireshark.desktop"
- "wireshark.png"
- "$_gitmod::git+https://code.wireshark.org/git/wireshark")
-conflicts=('wireshark-gtk')
-options=('strip' '!libtool')
+conflicts=('wireshark-common' 'wireshark-gtk' 'wireshark-qt' 'wireshark-cli')
install=$pkgname.install
pkgver() {
- cd $srcdir/$_gitmod
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/wireshark"
+ git describe --long --match=v\* | sed 's/^v//;s/-/+/g'
}
build() {
- cd $srcdir/$_gitmod
- ./autogen.sh
-
- mkdir $srcdir/build
- cd $srcdir/build
+ cd "$srcdir/wireshark"
+ mkdir -p build
+ cd build
- /usr/lib/python2.7/Tools/scripts/reindent.py $srcdir/$_gitmod/tools/ncp2222.py
-
- $srcdir/$_gitmod/configure \
- --prefix=/usr \
- --with-ssl \
- --with-krb5 \
- --with-zlib=yes \
- --with-lua=/usr/include/ \
- --with-portaudio \
- --with-python=/usr/bin/python2 \
- --enable-aircap \
- LDFLAGS="-llua" \
- CFLAGS="-Wno-error=old-style-definition -Wno-error=clobbered -Wno-error=unused-but-set-variable -fno-unit-at-a-time"
-
- make ${MAKEFLAGS} PYTHON=/usr/bin/python2
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ ninja
}
package() {
- cd $srcdir/build
- make ${MAKEFLAGS} DESTDIR=${pkgdir} install
-
- install -Dm644 ${srcdir}/wireshark.png ${pkgdir}/usr/share/icons/wireshark.png
- install -Dm644 ${srcdir}/wireshark.desktop ${pkgdir}/usr/share/applications/wireshark.desktop
-
- cd $pkgdir/usr/lib/
- ln -s libwsutil.so.0 libwsutil.so.3
- ln -s libwiretap.so.0 libwiretap.so.3
+ cd "$srcdir/wireshark/build"
+ DESTDIR="${pkgdir}" ninja install
}
# vim:set ts=2 sw=2:
diff --git a/wireshark.desktop b/wireshark.desktop
deleted file mode 100644
index f4317f6d04f7..000000000000
--- a/wireshark.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-GenericName=Wireshark
-Comment=Network protocol analyzer
-Name=wireshark
-Exec=wireshark
-Icon=/usr/share/icons/wireshark.png
-Type=Application
-Terminal=false
-Categories=Application;Network;
diff --git a/wireshark.png b/wireshark.png
deleted file mode 100644
index 4e402630426f..000000000000
--- a/wireshark.png
+++ /dev/null
Binary files differ