summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--wireshark-git.install12
-rw-r--r--wireshark.sysusers1
4 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b53102552849..d92e360895cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Mar 9 12:59:03 UTC 2018
pkgbase = wireshark-git
pkgdesc = A free network protocol analyzer for Unix/Linux. GIT version
- pkgver = 2.5.1rc0+544+g1ac90d5254
+ pkgver = 2.9.1rc0+426+g5eb8edf1cb
pkgrel = 1
url = https://www.wireshark.org/
install = wireshark-git.install
@@ -23,7 +21,6 @@ pkgbase = wireshark-git
depends = qt5-tools
depends = qt5-svg
depends = desktop-file-utils
- depends = hicolor-icon-theme
depends = gnutls
depends = krb5
depends = libnghttp2
@@ -39,7 +36,9 @@ pkgbase = wireshark-git
conflicts = wireshark-cli
replaces = ethereal
source = git+https://github.com/wireshark/wireshark
- sha256sums = SKIP
+ source = wireshark.sysusers
+ sha512sums = SKIP
+ sha512sums = 3956c1226e64f0ce4df463f80b55b15eed06ecd9b8703b3e8309d4236a6e1ca84e43007336f3987bc862d8a5e7cfcaaf6653125d2a34999a0f1357c52e7c4990
pkgname = wireshark-git
diff --git a/PKGBUILD b/PKGBUILD
index e24ec94f164a..4c59f075b999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel Nagy <danielnagy at gmx de>
pkgname=wireshark-git
-pkgver=2.5.1rc0+544+g1ac90d5254
+pkgver=2.9.1rc0+426+g5eb8edf1cb
pkgrel=1
pkgdesc="A free network protocol analyzer for Unix/Linux. GIT version"
arch=('i686' 'x86_64')
@@ -20,11 +20,8 @@ depends=(
'qt5-multimedia'
'qt5-tools'
'qt5-svg' # for SVG icons in the Qt GUI
- # wireshark-gtk (deprecated) depedencies
- #'portaudio'
- # shared between the GUI (for post-installation hook)
+ # for post-installation hook
'desktop-file-utils'
- 'hicolor-icon-theme'
# optional dependencies for improved dissection or features
'gnutls' # for SSL decryption using RSA keys
@@ -50,8 +47,10 @@ install=$pkgname.install
# clone --mirror", it pulls 830MB including all draft patches... As a
# workaround, use the Github mirror which should pull in "only" 424M.
#source=("git+https://code.wireshark.org/git/wireshark")
-source=("git+https://github.com/wireshark/wireshark")
-sha256sums=('SKIP')
+source=("git+https://github.com/wireshark/wireshark"
+ wireshark.sysusers)
+sha512sums=('SKIP'
+ '3956c1226e64f0ce4df463f80b55b15eed06ecd9b8703b3e8309d4236a6e1ca84e43007336f3987bc862d8a5e7cfcaaf6653125d2a34999a0f1357c52e7c4990')
pkgver() {
@@ -67,7 +66,8 @@ build() {
cmake .. -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_BCG729=OFF
ninja
}
@@ -76,6 +76,7 @@ package() {
DESTDIR="${pkgdir}" ninja install
# GID for wireshark is 150
+ install -Dm644 "${srcdir}/wireshark.sysusers" "${pkgdir}/usr/lib/sysusers.d/wireshark.conf"
chgrp 150 "${pkgdir}/usr/bin/dumpcap"
chmod 754 "${pkgdir}/usr/bin/dumpcap"
}
diff --git a/wireshark-git.install b/wireshark-git.install
index 9d1498aa60bb..f18fab8ff533 100644
--- a/wireshark-git.install
+++ b/wireshark-git.install
@@ -1,18 +1,8 @@
post_install() {
- getent group wireshark >/dev/null 2>&1 || groupadd -g 150 wireshark &>/dev/null
-
- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip CAP_DAC_OVERRIDE+eip' usr/bin/dumpcap
+ post_upgrade
echo "NOTE: To run wireshark as normal user you have to add yourself into wireshark group"
}
post_upgrade() {
- getent group wireshark >/dev/null 2>&1 || groupadd -g 150 wireshark &>/dev/null
-
setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip CAP_DAC_OVERRIDE+eip' usr/bin/dumpcap
}
-
-post_remove() {
- if getent group wireshark >/dev/null 2>&1; then
- groupdel wireshark
- fi
-}
diff --git a/wireshark.sysusers b/wireshark.sysusers
new file mode 100644
index 000000000000..0337b2eee0ae
--- /dev/null
+++ b/wireshark.sysusers
@@ -0,0 +1 @@
+g wireshark 150 - -