summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--config_readme16
-rw-r--r--environment10
-rw-r--r--wiretrustee-signal.service17
-rw-r--r--wiretrustee@.service17
7 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de46ea6fe6c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = wiretrustee-bin
+ pkgdesc = Connect your devices into a single secure private WireGuard®-based mesh network
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://wiretrustee.com
+ arch = x86_64
+ arch = aarch64
+ license = BSD
+ provides = wiretrustee
+ conflicts = wiretrustee
+ source = config_readme
+ source = environment
+ source = wiretrustee@.service
+ source = wiretrustee-signal.service
+ sha256sums = e6e2bb1687510b9381202d95beb27b1bfbe30033f4f038e4bdde61e7a3f65f22
+ sha256sums = c72c3f27ee2f2fbb232108781e38f41d7f04272d11a42f59938541ac591bd393
+ sha256sums = 672235231a73743878d77e94827c5aba326464dae63457f94cd51708ac84ba58
+ sha256sums = 79cae90dff3bb3177762b9d3a9c69e69ef79ced3dc3a85529ff5050bf17bcd85
+ source_x86_64 = wiretrustee-bin-0.0.7.tar.gz::https://github.com/wiretrustee/wiretrustee/releases/download/v0.0.7/wiretrustee_0.0.7_linux_amd64.tar.gz
+ sha256sums_x86_64 = 5d11b291346badadfc8589d04877b6912a7133e28d3c7bdfd2795cec706a9bfe
+ source_aarch64 = wiretrustee-bin-0.0.7.tar.gz::https://github.com/wiretrustee/wiretrustee/releases/download/v0.0.7/wiretrustee_0.0.7_linux_arm64.tar.gz
+ sha256sums_aarch64 = ce02dbfee5e0fbe4e586d4f2a1384c661774c19b0bcbc29b180b83f40567d9a6
+
+pkgname = wiretrustee-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cac4d4bafa49
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c4ec52fc99a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: tarball <bootctl@gmail.com>
+
+pkgname='wiretrustee-bin'
+_pkgname="${pkgname%-bin}"
+pkgver=0.0.7
+pkgrel=1
+pkgdesc='Connect your devices into a single secure private WireGuard®-based mesh network'
+url='https://wiretrustee.com'
+arch=(x86_64 aarch64)
+license=('BSD')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=()
+makedepends=()
+optdepends=()
+
+source=(
+ 'config_readme'
+ 'environment'
+ 'wiretrustee@.service'
+ 'wiretrustee-signal.service'
+)
+sha256sums=(
+ 'e6e2bb1687510b9381202d95beb27b1bfbe30033f4f038e4bdde61e7a3f65f22'
+ 'c72c3f27ee2f2fbb232108781e38f41d7f04272d11a42f59938541ac591bd393'
+ '672235231a73743878d77e94827c5aba326464dae63457f94cd51708ac84ba58'
+ '79cae90dff3bb3177762b9d3a9c69e69ef79ced3dc3a85529ff5050bf17bcd85'
+)
+
+_base_url="https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux"
+
+source_x86_64=("${pkgname}-${pkgver}.tar.gz::${_base_url}_amd64.tar.gz")
+sha256sums_x86_64=('5d11b291346badadfc8589d04877b6912a7133e28d3c7bdfd2795cec706a9bfe')
+
+source_aarch64=("${pkgname}-${pkgver}.tar.gz::${_base_url}_arm64.tar.gz")
+sha256sums_aarch64=('ce02dbfee5e0fbe4e586d4f2a1384c661774c19b0bcbc29b180b83f40567d9a6')
+
+package() {
+ # binary
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # config directory
+ install -Ddm755 -o root -g root "${pkgdir}/etc/${_pkgname}"
+ install -Dm644 "config_readme" "${pkgdir}/etc/${_pkgname}/README"
+
+ # environment file
+ install -Dm644 environment "${pkgdir}/etc/default/${_pkgname}"
+
+ # systemd units
+ for kind in @ -signal; do
+ install -Dm644 "${_pkgname}${kind}.service" \
+ "${pkgdir}/usr/lib/systemd/system/${_pkgname}${kind}.service"
+ done
+
+ # license
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/config_readme b/config_readme
new file mode 100644
index 000000000000..b494dc9a0a31
--- /dev/null
+++ b/config_readme
@@ -0,0 +1,16 @@
+Configure your Wiretrustee instance by running:
+
+# wiretrustee init \
+ --config /etc/wiretrustee/main.json \
+ --stunURLs stun:stun.wiretrustee.com:3468,stun:stun.l.google.com:19302 \
+ --turnURLs <TURN User>:<TURN password>@turn:stun.wiretrustee.com:3468 \
+ --signalAddr signal.wiretrustee.com:10000 \
+ --wgLocalAddr 10.30.30.1/24 \
+ --log-level info
+
+Then enable and start the service:
+
+# systemctl enable --now wiretrustee@main
+
+Read more at https://github.com/wiretrustee/wiretrustee
+
diff --git a/environment b/environment
new file mode 100644
index 000000000000..ea6f1dd95a32
--- /dev/null
+++ b/environment
@@ -0,0 +1,10 @@
+# additional options to pass to all wiretrustee services
+# see more at 'wiretrustee --help'
+WIRETRUSTEE_ARGS="--log-level info"
+
+# additional options to pass to wiretrustee clients
+WIRETRUSTEE_CLIENT_ARGS="${WIRETRUSTEE_ARGS}"
+
+# additional options to pass to wiretrustee signal service
+WIRETRUSTEE_SIGNAL_ARGS="${WIRETRUSTEE_ARGS} --port 10000"
+
diff --git a/wiretrustee-signal.service b/wiretrustee-signal.service
new file mode 100644
index 000000000000..4bf2cce98951
--- /dev/null
+++ b/wiretrustee-signal.service
@@ -0,0 +1,17 @@
+[Unit]
+Description = Wiretrustee Signal Service
+Documentation = https://github.com/wiretrustee/wiretrustee#readme
+After = multi-user.target network-online.target
+Wants = network-online.target
+
+[Service]
+Type = simple
+EnvironmentFile = -/etc/default/wiretrustee
+ExecStart = /usr/bin/wiretrustee signal $WIRETRUSTEE_SIGNAL_ARGS
+Restart = on-failure
+RestartSec = 5
+TimeoutStopSec = 5
+
+[Install]
+WantedBy = multi-user.target
+
diff --git a/wiretrustee@.service b/wiretrustee@.service
new file mode 100644
index 000000000000..25a471bbb4f7
--- /dev/null
+++ b/wiretrustee@.service
@@ -0,0 +1,17 @@
+[Unit]
+Description = Wiretrustee Service (%i)
+Documentation = https://github.com/wiretrustee/wiretrustee#readme
+After = multi-user.target network-online.target
+Wants = network-online.target
+
+[Service]
+Type = simple
+EnvironmentFile = -/etc/default/wiretrustee
+ExecStart = /usr/bin/wiretrustee up --config /etc/wiretrustee/%i.json $WIRETRUSTEE_CLIENT_ARGS
+Restart = on-failure
+RestartSec = 5
+TimeoutStopSec = 5
+
+[Install]
+WantedBy = multi-user.target
+